summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-30 22:18:06 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-30 22:18:06 +0000
commit7b9e5242f0133917731642264a74e146fb4c1072 (patch)
treeb7f0b9e12c83cc9afb97018fbb622f67370d27b9 /kde-base/kmail
parent0.8.33 version bump. (diff)
downloadgentoo-2-7b9e5242f0133917731642264a74e146fb4c1072.tar.gz
gentoo-2-7b9e5242f0133917731642264a74e146fb4c1072.tar.bz2
gentoo-2-7b9e5242f0133917731642264a74e146fb4c1072.zip
Hopefully fix compilation with gcc-4.4, bug 396343
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog8
-rw-r--r--kde-base/kmail/files/kmail-4.7.4-gcc44.patch11
-rw-r--r--kde-base/kmail/kmail-4.7.4-r1.ebuild84
3 files changed, 102 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index 8b19a97d642f..32634a2c1757 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.268 2011/12/12 01:17:55 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.269 2011/12/30 22:18:06 dilfridge Exp $
+
+*kmail-4.7.4-r1 (30 Dec 2011)
+
+ 30 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kmail-4.7.4-r1.ebuild, +files/kmail-4.7.4-gcc44.patch:
+ Hopefully fix compilation with gcc-4.4, bug 396343
12 Dec 2011; Jonathan Callen <abcd@gentoo.org>
-files/kmail-4.4.10-asyncako.patch:
diff --git a/kde-base/kmail/files/kmail-4.7.4-gcc44.patch b/kde-base/kmail/files/kmail-4.7.4-gcc44.patch
new file mode 100644
index 000000000000..363620292c70
--- /dev/null
+++ b/kde-base/kmail/files/kmail-4.7.4-gcc44.patch
@@ -0,0 +1,11 @@
+diff -urN kmail-4.7.4.orig/messagecomposer/akonadisender.cpp kmail-4.7.4/messagecomposer/akonadisender.cpp
+--- kmail-4.7.4.orig/messagecomposer/akonadisender.cpp 2011-12-02 00:25:40.000000000 +0100
++++ kmail-4.7.4/messagecomposer/akonadisender.cpp 2011-12-30 23:10:05.151509937 +0100
+@@ -38,7 +38,6 @@
+ #include <messagecore/stringutil.h>
+ #include <messagecore/messagehelpers.h>
+
+-using namespace KMime;
+ using namespace KMime::Types;
+ using namespace KPIM;
+ using namespace MailTransport;
diff --git a/kde-base/kmail/kmail-4.7.4-r1.ebuild b/kde-base/kmail/kmail-4.7.4-r1.ebuild
new file mode 100644
index 000000000000..a3f55a6b4451
--- /dev/null
+++ b/kde-base/kmail/kmail-4.7.4-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.7.4-r1.ebuild,v 1.1 2011/12/30 22:18:06 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+KDE_SCM="git"
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS=""
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# bug 393147
+
+KMEXTRACTONLY="
+ akonadi_next/
+ calendarsupport/
+ korganizer/
+ kresources/
+ libkleo/
+ libkpgp/
+ libkdepimdbusinterfaces/
+ kdgantt2/
+"
+KMCOMPILEONLY="
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ templateparser/
+ incidenceeditor-ng/
+ calendarsupport/
+"
+KMEXTRA="
+ kmailcvt/
+ ksendemail/
+ libksieve/
+ mailcommon/
+ ontologies/
+ plugins/messageviewer/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+PATCHES=( "${FILESDIR}/${PN}-4.7.4-gcc44.patch" )
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+}