summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
committerChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
commitb5c71598bd396d68feb09813aad0c75a45f81a3a (patch)
treeb738e19f08caad8c28f1ee6bee7051613495e2de /kde-base/kimono
parentFix docs installation, bug 487448 by Juergen Rose. Add -fno-strict-aliasing t... (diff)
downloadgentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.tar.gz
gentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.tar.bz2
gentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.zip
Version bump KDE SC 4.11.2
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/kimono')
-rw-r--r--kde-base/kimono/ChangeLog7
-rw-r--r--kde-base/kimono/kimono-4.11.2-r1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/kimono/ChangeLog b/kde-base/kimono/ChangeLog
index 6344630e577a..0f5278f393fc 100644
--- a/kde-base/kimono/ChangeLog
+++ b/kde-base/kimono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kimono
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.87 2013/09/03 19:50:08 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.88 2013/10/09 23:04:02 creffett Exp $
+
+*kimono-4.11.2-r1 (08 Oct 2013)
+
+ 08 Oct 2013; Chris Reffett <creffett@gentoo.org> +kimono-4.11.2-r1.ebuild:
+ Version bump KDE SC 4.11.2
03 Sep 2013; Chris Reffett <creffett@gentoo.org> -kimono-4.11.0.ebuild:
Drop KDE 4.11.0
diff --git a/kde-base/kimono/kimono-4.11.2-r1.ebuild b/kde-base/kimono/kimono-4.11.2-r1.ebuild
new file mode 100644
index 000000000000..2a32aaefdd9e
--- /dev/null
+++ b/kde-base/kimono/kimono-4.11.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/kimono-4.11.2-r1.ebuild,v 1.1 2013/10/09 23:04:02 creffett Exp $
+
+EAPI=5
+
+inherit mono-env kde4-base
+
+DESCRIPTION="C# bindings for KDE"
+KEYWORDS=" ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug plasma semantic-desktop"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep qyoto 'webkit')
+ $(add_kdebase_dep smokeqt)
+ $(add_kdebase_dep smokekde 'semantic-desktop?')
+ plasma? ( $(add_kdebase_dep smokeqt 'webkit') )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -i "/add_subdirectory( examples )/ s:^:#:" plasma/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ -DWITH_Soprano=OFF
+ )
+ kde4-base_src_configure
+}