summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:02:20 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:02:20 +0000
commita53d14810061ef90da49c68a449eaf797b21236b (patch)
tree0dfa9a7a56481c6bec92b5598f00d568454c47de /kde-base/kicker
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-a53d14810061ef90da49c68a449eaf797b21236b.tar.gz
gentoo-2-a53d14810061ef90da49c68a449eaf797b21236b.tar.bz2
gentoo-2-a53d14810061ef90da49c68a449eaf797b21236b.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kicker')
-rw-r--r--kde-base/kicker/ChangeLog7
-rw-r--r--kde-base/kicker/kicker-3.5.9.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/kicker/ChangeLog b/kde-base/kicker/ChangeLog
index 0be363069586..96ae06cd3d0b 100644
--- a/kde-base/kicker/ChangeLog
+++ b/kde-base/kicker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kicker
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/ChangeLog,v 1.91 2008/02/17 02:34:20 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/ChangeLog,v 1.92 2008/02/20 23:02:20 philantrop Exp $
+
+*kicker-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org> +kicker-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> -kicker-3.5.5.ebuild,
-kicker-3.5.6.ebuild, -kicker-3.5.7.ebuild:
diff --git a/kde-base/kicker/kicker-3.5.9.ebuild b/kde-base/kicker/kicker-3.5.9.ebuild
new file mode 100644
index 000000000000..189a7025497b
--- /dev/null
+++ b/kde-base/kicker/kicker-3.5.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/kicker-3.5.9.ebuild,v 1.1 2008/02/20 23:02:20 philantrop Exp $
+
+KMNAME=kdebase
+EAPI="1"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-03.tar.bz2"
+
+DESCRIPTION="Kicker is the KDE application starter panel, also capable of some useful applets and extensions."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility xcomposite"
+
+RDEPEND="
+>=kde-base/libkonq-${PV}:${SLOT}
+>=kde-base/kdebase-data-${PV}:${SLOT}
+ x11-libs/libXau
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ xcomposite? ( x11-libs/libXcomposite )"
+
+DEPEND="${RDEPEND}"
+
+KMCOPYLIB="libkonq libkonq"
+KMEXTRACTONLY="libkonq
+ kdm/kfrontend/themer/"
+KMCOMPILEONLY="kdmlib/"
+
+src_compile() {
+ myconf="$myconf $(use_with xcomposite composite)"
+ kde-meta_src_compile
+}