summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-11-20 13:46:03 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-11-20 13:46:03 +0000
commitba8cad936fd6aca6d8c5c7c6d3be0df57ed747e5 (patch)
tree855cabd3319c971ad2fa2c4275a0058bf49fa19d /kde-base/kdeutils
parentamd64 stable wrt #199740 (diff)
downloadgentoo-2-ba8cad936fd6aca6d8c5c7c6d3be0df57ed747e5.tar.gz
gentoo-2-ba8cad936fd6aca6d8c5c7c6d3be0df57ed747e5.tar.bz2
gentoo-2-ba8cad936fd6aca6d8c5c7c6d3be0df57ed747e5.zip
Added a patch to fix a problem with the XF86Audio* key handlers not working when there's no master channel (e. g. you have a mute key that stopped working in KDE). Fixes bug 198015. Thanks to Kelvie Wong for creating and submitting said patch.
(Portage version: 2.1.3.19)
Diffstat (limited to 'kde-base/kdeutils')
-rw-r--r--kde-base/kdeutils/ChangeLog11
-rw-r--r--kde-base/kdeutils/files/digest-kdeutils-3.5.8-r16
-rw-r--r--kde-base/kdeutils/files/kmilo-3.5.8-198015_XF86Audio.patch84
-rw-r--r--kde-base/kdeutils/kdeutils-3.5.8-r1.ebuild58
4 files changed, 158 insertions, 1 deletions
diff --git a/kde-base/kdeutils/ChangeLog b/kde-base/kdeutils/ChangeLog
index f8f1c6a4514b..b38edabe7b99 100644
--- a/kde-base/kdeutils/ChangeLog
+++ b/kde-base/kdeutils/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for kde-base/kdeutils
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/ChangeLog,v 1.214 2007/10/19 22:47:05 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/ChangeLog,v 1.215 2007/11/20 13:46:02 philantrop Exp $
+
+*kdeutils-3.5.8-r1 (20 Nov 2007)
+
+ 20 Nov 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kmilo-3.5.8-198015_XF86Audio.patch, +kdeutils-3.5.8-r1.ebuild:
+ Added a patch to fix a problem with the XF86Audio* key handlers not working
+ when there's no master channel (e. g. you have a mute key that stopped
+ working in KDE). Fixes bug 198015. Thanks to Kelvie Wong for creating and
+ submitting said patch.
*kdeutils-3.5.8 (19 Oct 2007)
diff --git a/kde-base/kdeutils/files/digest-kdeutils-3.5.8-r1 b/kde-base/kdeutils/files/digest-kdeutils-3.5.8-r1
new file mode 100644
index 000000000000..d5ce5a414504
--- /dev/null
+++ b/kde-base/kdeutils/files/digest-kdeutils-3.5.8-r1
@@ -0,0 +1,6 @@
+MD5 4a5500af2f0170c9f74501093d5393ad kdeutils-3.5-patchset-02.tar.bz2 3019
+RMD160 b4598488995ed7dc7a86349cd68da426e2238773 kdeutils-3.5-patchset-02.tar.bz2 3019
+SHA256 54ddfbec990e3bff3139abf42755be24a450a8969eb77d41a5b0da4dc72580d6 kdeutils-3.5-patchset-02.tar.bz2 3019
+MD5 d1a0fcc83f35428a76cf7523a04ba19c kdeutils-3.5.8.tar.bz2 3059172
+RMD160 94267b9c08339c7310d65106110c9b9ef133d6f8 kdeutils-3.5.8.tar.bz2 3059172
+SHA256 7dcbe3361cc53f9dac4c1bf6f45952d3d2518bec56cd8c07b8e07b4c4f12d0ac kdeutils-3.5.8.tar.bz2 3059172
diff --git a/kde-base/kdeutils/files/kmilo-3.5.8-198015_XF86Audio.patch b/kde-base/kdeutils/files/kmilo-3.5.8-198015_XF86Audio.patch
new file mode 100644
index 000000000000..22d16983f88f
--- /dev/null
+++ b/kde-base/kdeutils/files/kmilo-3.5.8-198015_XF86Audio.patch
@@ -0,0 +1,84 @@
+From 5ddf8e7f68098ebb86d0023653e540edf119291d Mon Sep 17 00:00:00 2001
+From: Kelvie Wong <kelvie@ieee.org>
+Date: Sat, 3 Nov 2007 21:42:27 -0700
+Subject: [PATCH] KMilo: reintroduced support for kmix's user-set master channel
+ * uses the new masterDeviceIndex dcop call in KMix (from other patch)
+
+---
+ kmilo/generic/generic_monitor.cpp | 18 +++++++++++++-----
+ kmilo/generic/generic_monitor.h | 1 +
+ 2 files changed, 14 insertions(+), 5 deletions(-)
+
+diff --git a/kmilo/generic/generic_monitor.cpp b/kmilo/generic/generic_monitor.cpp
+index 51b96b1..fd7a47f 100644
+--- a/kmilo/generic/generic_monitor.cpp
++++ b/kmilo/generic/generic_monitor.cpp
+@@ -50,6 +50,7 @@ GenericMonitor::GenericMonitor(QObject *parent, const char *name, const QStringL
+ m_minVolume = 0;
+ m_maxVolume = 100;
+ m_volume = 50;
++ m_deviceIdx = 0;
+ }
+
+ GenericMonitor::~GenericMonitor()
+@@ -92,7 +93,14 @@ bool GenericMonitor::retrieveVolume()
+ {
+ bool kmix_error = false;
+
+- DCOPReply reply = kmixClient->call("absoluteVolume", 0);
++ // Set it to the master, or 0 (from GenericMonitor()) if this dcop
++ // call doesn't exist or various other errors. It used to be
++ // hard-coded to 0 anyways.
++ DCOPReply reply = kmixClient->call("masterDeviceIndex");
++ if (reply.isValid())
++ m_deviceIdx = reply;
++
++ reply = kmixClient->call("absoluteVolume", m_deviceIdx);
+ if (reply.isValid())
+ m_volume = reply;
+ else
+@@ -104,7 +112,7 @@ bool GenericMonitor::retrieveVolume()
+ if (kapp->startServiceByDesktopName("kmix")==0) // trying to start kmix
+ {
+ // trying again
+- reply = kmixClient->call("absoluteVolume", 0);
++ reply = kmixClient->call("absoluteVolume", m_deviceIdx);
+ if (reply.isValid())
+ {
+ m_volume = reply;
+@@ -122,9 +130,9 @@ bool GenericMonitor::retrieveVolume()
+
+ return false;
+ } else {
+- reply = kmixClient->call("absoluteVolumeMax", 0);
++ reply = kmixClient->call("absoluteVolumeMax", m_deviceIdx);
+ m_maxVolume = reply;
+- reply = kmixClient->call("absoluteVolumeMin", 0);
++ reply = kmixClient->call("absoluteVolumeMin", m_deviceIdx);
+ m_minVolume = reply;
+ return true;
+ }
+@@ -165,7 +173,7 @@ void GenericMonitor::displayVolume()
+
+ // If we got this far, the DCOP communication with kmix works,
+ // so we don't have to test the result.
+- kmixClient->send("setAbsoluteVolume", 0, m_volume);
++ kmixClient->send("setAbsoluteVolume", m_deviceIdx, m_volume);
+
+ // if mute then unmute
+ if (m_mute)
+diff --git a/kmilo/generic/generic_monitor.h b/kmilo/generic/generic_monitor.h
+index 7a0ba51..d04274f 100644
+--- a/kmilo/generic/generic_monitor.h
++++ b/kmilo/generic/generic_monitor.h
+@@ -74,6 +74,7 @@ private:
+
+ DCOPRef *kmixClient, *kmixWindow;
+
++ int m_deviceIdx;
+ int m_progress;
+ long m_volume, m_oldVolume;
+ bool m_mute;
+--
+1.5.3.4
+
diff --git a/kde-base/kdeutils/kdeutils-3.5.8-r1.ebuild b/kde-base/kdeutils/kdeutils-3.5.8-r1.ebuild
new file mode 100644
index 000000000000..43a2fffd87fd
--- /dev/null
+++ b/kde-base/kdeutils/kdeutils-3.5.8-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/kdeutils-3.5.8-r1.ebuild,v 1.1 2007/11/20 13:46:02 philantrop Exp $
+
+inherit kde-dist eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdeutils-3.5-patchset-02.tar.bz2"
+
+DESCRIPTION="KDE utilities."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt kdehiddenvisibility pbbuttonsd snmp xscreensaver"
+
+BOTH_DEPEND="~kde-base/kdebase-${PV}
+ snmp? ( net-analyzer/net-snmp )
+ pbbuttonsd? ( app-laptop/pbbuttonsd )
+ dev-lang/python
+ dev-libs/gmp
+ x11-libs/libXtst"
+
+RDEPEND="${BOTH_DEPEND}
+ crypt? ( app-crypt/gnupg )"
+
+DEPEND="${BOTH_DEPEND}
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ x11-libs/libX11
+ x11-proto/xproto
+ virtual/os-headers"
+
+PATCHES="${FILESDIR}/superkaramba-3.5.7-network_sensor.patch
+ ${FILESDIR}/klaptopdaemon-3.5.7-has_acpi_sleep.patch
+ ${FILESDIR}/kmilo-3.5.8-198015_XF86Audio.patch"
+EPATCH_EXCLUDE="klaptopdaemon-3.5-suspend2+xsession-errors.diff
+ klaptopdaemon-3.5-lock-and-hibernate.diff"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix some desktop files
+ sed -i -e "s:Hidden=true:Hidden=false:" "${S}/ksim/ksim.desktop" \
+ || die "sed (ksim) failed"
+ sed -i -e "s:\(^Type=\)Service:\1Application:" "${S}/kdelirc/irkick/irkick.desktop" \
+ || die "sed (irkick) failed"
+ sed -i -e "s:\(^Init=.*\):X-\1:" "${S}/klaptopdaemon/applnk/laptop.desktop" \
+ || die "sed (laptop) failed"
+}
+
+src_compile() {
+ local myconf="$(use_with snmp)
+ $(use_with pbbuttonsd powerbook)
+ $(use_with xscreensaver)
+ --without-xmms"
+
+ use crypt || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kgpg"
+
+ kde_src_compile
+}