summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
commit588eb8e56926b65029e4de63aa398e51ed8cc9b8 (patch)
tree356a5e95843b62ad54fc9c77facba6ff67c4db94 /kde-base/kdeplasma-addons
parentx86 stable, bug 323729 (diff)
downloadgentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.tar.gz
gentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.tar.bz2
gentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.zip
[kde-base] Bump KDE SC 4.4.5 =)
(Portage version: 2.2_rc67_p182/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog8
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.4.5.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index c65435163764..badaa6124dcc 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.63 2010/06/27 18:36:19 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.64 2010/06/30 15:37:03 alexxy Exp $
+
+*kdeplasma-addons-4.4.5 (30 Jun 2010)
+
+ 30 Jun 2010; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdeplasma-addons-4.4.5.ebuild:
+ Version bump
27 Jun 2010; Christian Faulhammer <fauli@gentoo.org>
kdeplasma-addons-4.4.4.ebuild:
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.4.5.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.4.5.ebuild
new file mode 100644
index 000000000000..475f3836a716
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.4.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.4.5.ebuild,v 1.1 2010/06/30 15:37:03 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdeplasma-addons"
+WEBKIT_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines."
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2 LGPL-2"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug desktopglobe exif qalculate qwt rss scim semantic-desktop"
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ dev-libs/libattica
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep krunner)
+ $(add_kdebase_dep plasma-workspace 'rss?')
+ x11-misc/shared-mime-info
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ rss? ( $(add_kdebase_dep kdepimlibs 'semantic-desktop') )
+ scim? ( app-i18n/scim )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+# kde-misc/plasmaboard: moved here in 4.3.65
+# kde-misc/qalculate-applet: since 4.4.0
+RDEPEND="${COMMON_DEPEND}
+ !kdeprefix? (
+ !kde-misc/plasmaboard
+ !kde-misc/qalculate-applet
+ )
+"
+
+# kdebase-data: some svg icons moved from data directly here.
+add_blocker kdebase-data '<4.2.88'
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.3-cmake.patch"
+)
+
+src_prepare() {
+ sed -e 's/${KDE4WORKSPACE_PLASMACLOCK_LIBRARY}/plasmaclock/g' \
+ -e 's/${KDE4WORKSPACE_WEATHERION_LIBRARY}/weather_ion/g' \
+ -e 's/${KDE4WORKSPACE_TASKMANAGER_LIBRARY}/taskmanager/g' \
+ -i {libs/plasmaweather,applets/{binary-clock,fuzzy-clock,weather,weatherstation,lancelot/app/src}}/CMakeLists.txt \
+ || die "Failed to patch CMake files"
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EKDEDIR}/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_with rss KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with scim)
+ )
+
+ kde4-base_src_configure
+}