summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 17:04:40 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 17:04:40 +0000
commit329e24c6d3632f0cb8dab1b66ec563fef3c0c802 (patch)
treee4a6db2b97089df16a60d6a9f362d6b248de6982 /kde-base/kdeplasma-addons
parentVersion bump KDE 4.4.1 (diff)
downloadgentoo-2-329e24c6d3632f0cb8dab1b66ec563fef3c0c802.tar.gz
gentoo-2-329e24c6d3632f0cb8dab1b66ec563fef3c0c802.tar.bz2
gentoo-2-329e24c6d3632f0cb8dab1b66ec563fef3c0c802.zip
Version bump KDE 4.4.1
(Portage version: 2.2_rc63/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog8
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.4.1.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index 0c109709a72e..4f7fe03c2cba 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.50 2010/02/20 10:39:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.51 2010/03/02 17:04:40 tampakrap Exp $
+
+*kdeplasma-addons-4.4.1 (02 Mar 2010)
+
+ 02 Mar 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kdeplasma-addons-4.4.1.ebuild:
+ Version bump
20 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
kdeplasma-addons-4.3.5.ebuild:
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.4.1.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.4.1.ebuild
new file mode 100644
index 000000000000..cdb905e0b9f3
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.4.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.4.1.ebuild,v 1.1 2010/03/02 17:04:40 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdeplasma-addons"
+WEBKIT_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines."
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2 LGPL-2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug desktopglobe exif qalculate qwt scim semantic-desktop"
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ dev-libs/libattica
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep krunner)
+ $(add_kdebase_dep plasma-workspace)
+ x11-misc/shared-mime-info
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+# kde-misc/plasmaboard: moved here in 4.3.65
+RDEPEND="${COMMON_DEPEND}
+ !kdeprefix? ( !kde-misc/plasmaboard )
+"
+
+# kdebase-data: some svg icons moved from data directly here.
+add_blocker kdebase-data '<4.2.88'
+
+src_prepare() {
+ sed -e 's/${KDE4WORKSPACE_PLASMACLOCK_LIBRARY}/plasmaclock/g' \
+ -e 's/${KDE4WORKSPACE_WEATHERION_LIBRARY}/weather_ion/g' \
+ -e 's/${KDE4WORKSPACE_TASKMANAGER_LIBRARY}/taskmanager/g' \
+ -i {libs/plasmaweather,applets/{binary-clock,fuzzy-clock,weather,weatherstation,lancelot/app/src}}/CMakeLists.txt \
+ || die "Failed to patch CMake files"
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EKDEDIR}/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with scim)
+ )
+
+ kde4-base_src_configure
+}