summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
commit15e1e7fdd1e191927f169caf35f9223d23a57246 (patch)
treea24b9205d75050edee2d793b88c839b440af63fc /kde-base/kdeplasma-addons
parentAdd net-misc/leechcraft-launchy, thanks to 0xd34df00d (diff)
downloadgentoo-2-15e1e7fdd1e191927f169caf35f9223d23a57246.tar.gz
gentoo-2-15e1e7fdd1e191927f169caf35f9223d23a57246.tar.bz2
gentoo-2-15e1e7fdd1e191927f169caf35f9223d23a57246.zip
Version bump KDE SC 4.9.1
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog7
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.9.1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index d9f219beb993..396085c93f85 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.147 2012/09/03 13:59:39 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.148 2012/09/04 18:45:35 johu Exp $
+
+*kdeplasma-addons-4.9.1 (04 Sep 2012)
+
+ 04 Sep 2012; Johannes Huber <johu@gentoo.org> +kdeplasma-addons-4.9.1.ebuild:
+ Version bump KDE SC 4.9.1
03 Sep 2012; Johannes Huber <johu@gentoo.org>
-files/kdeplasma-addons-4.6.2-optional-akonadi.patch,
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.1.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.1.ebuild
new file mode 100644
index 000000000000..3d9fd69b680e
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.1.ebuild,v 1.1 2012/09/04 18:45:35 johu Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2 LGPL-2"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug desktopglobe exif fcitx ibus qalculate qwt scim semantic-desktop"
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep krunner)
+ $(add_kdebase_dep plasma-workspace 'semantic-desktop=')
+ x11-misc/shared-mime-info
+ attica? ( dev-libs/libattica )
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ fcitx? ( app-i18n/fcitx[dbus(+)] )
+ ibus? ( app-i18n/ibus )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+ semantic-desktop? (
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep plasma-workspace 'rss')
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+RDEPEND="${COMMON_DEPEND}
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_with ibus)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with scim)
+ )
+
+ kde4-base_src_configure
+}