summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-04 19:14:09 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-04 19:14:09 +0000
commitb635da4d6a5d3adc02954e54eac873b1ccef912d (patch)
tree20c5621fa841bba0ea00b22c0f7164dbce35a9b2 /kde-base/kdepimlibs
parentAdd missing DEPEND. #501740 (diff)
downloadgentoo-2-b635da4d6a5d3adc02954e54eac873b1ccef912d.tar.gz
gentoo-2-b635da4d6a5d3adc02954e54eac873b1ccef912d.tar.bz2
gentoo-2-b635da4d6a5d3adc02954e54eac873b1ccef912d.zip
Version bump KDE SC 4.12.3
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog7
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.12.3.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index bc7f44aaf31f..c00cc1c040d3 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.247 2014/02/23 10:01:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.248 2014/03/04 19:13:27 johu Exp $
+
+*kdepimlibs-4.12.3 (04 Mar 2014)
+
+ 04 Mar 2014; Johannes Huber <johu@gentoo.org> +kdepimlibs-4.12.3.ebuild:
+ Version bump KDE SC 4.12.3
23 Feb 2014; Agostino Sarubbo <ago@gentoo.org> -kdepimlibs-4.11.2-r1.ebuild,
-kdepimlibs-4.11.2-r2.ebuild:
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.12.3.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.12.3.ebuild
new file mode 100644
index 000000000000..7a59f20086cd
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.12.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.12.3.ebuild,v 1.1 2014/03/04 19:13:27 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="debug ldap prison"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ !kde-misc/akonadi-social-utils
+ $(add_kdebase_dep nepomuk-core)
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ >=app-crypt/gpgme-1.1.6
+ >=app-office/akonadi-server-1.10.43
+ >=dev-libs/boost-1.35.0-r5:=
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ >=dev-libs/qjson-0.8.1
+ media-libs/phonon
+ x11-misc/shared-mime-info
+ prison? ( media-libs/prison )
+ ldap? ( net-nds/openldap )
+"
+# boost is not linked to, but headers which include it are installed
+# bug #418071
+RDEPEND="${DEPEND}
+ !=kde-base/kdepim-runtime-4.10*
+ !=kde-base/kdepim-runtime-4.11*
+ !<kde-base/kdepim-runtime-4.4.11.1-r2
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.9.1-boostincludes.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_find_package ldap)
+ $(cmake-utils_use_find_package prison)
+ )
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+ rm "${ED}"/usr/share/apps/cmake/modules/FindQtOAuth.cmake #Collides with net-im/choqok
+}