summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 20:41:44 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 20:41:44 +0000
commit44d29324fe0cfa65dfdf6f33fdf964e2b61f8c08 (patch)
tree565fbe3d25f5d37e8bbf2d1cf9af89d44c0b3cf5 /kde-base/kdepimlibs
parentVersion bump KDE 4.4.3 (diff)
downloadgentoo-2-44d29324fe0cfa65dfdf6f33fdf964e2b61f8c08.tar.gz
gentoo-2-44d29324fe0cfa65dfdf6f33fdf964e2b61f8c08.tar.bz2
gentoo-2-44d29324fe0cfa65dfdf6f33fdf964e2b61f8c08.zip
Version bump KDE 4.4.3
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog7
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.4.3.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index fb75b346e752..b986a04a19f5 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.69 2010/03/31 22:28:14 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.70 2010/05/03 20:41:44 alexxy Exp $
+
+*kdepimlibs-4.4.3 (03 May 2010)
+
+ 03 May 2010; Alexey Shvetsov <alexxy@gentoo.org> +kdepimlibs-4.4.3.ebuild:
+ Version bump
31 Mar 2010; Dror Levin <spatz@gentoo.org> -kdepimlibs-4.3.4.ebuild,
-kdepimlibs-4.4.0.ebuild, -kdepimlibs-4.4.0-r1.ebuild:
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.4.3.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.4.3.ebuild
new file mode 100644
index 000000000000..3293b7fb0ead
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.4.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.4.3.ebuild,v 1.1 2010/05/03 20:41:44 alexxy Exp $
+
+EAPI="3"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="+akonadi debug +handbook ldap"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ >=dev-libs/boost-1.35.0-r5
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ akonadi? ( >=app-office/akonadi-server-1.3.1 )
+ ldap? ( net-nds/openldap )
+"
+RDEPEND="${DEPEND}"
+
+# libakonadi-kcal moved here from akonadi in 4.3.86
+add_blocker akonadi '<4.3.86'
+# @since 4.3 - libkholidays is in kdepimlibs now
+add_blocker libkholidays
+# @since 4.4 - kontactinterfaces is in kdepimlibs now
+add_blocker kontactinterfaces
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if ! use akonadi; then
+ sed -e '/find_package(Akonadi/s/^/# DISABLED /' \
+ -e '/macro_log_feature(Akonadi_FOUND/s/TRUE/FALSE/' \
+ -e '/add_subdirectory(akonadi)/s/^/# DISABLED /' \
+ -e '/add_subdirectory(mailtransport)/s/^/# DISABLED /' \
+ -i CMakeLists.txt || die "failed to disable akonadi"
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap)
+ )
+
+ kde4-base_src_configure
+}