summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-18 11:24:17 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-18 11:24:17 +0000
commit14c988d01f8c84ab2bd2faa3c01c646602dc1692 (patch)
tree4b095bcf239f3426af85e14e94933b79e8588042 /kde-base/kdepimlibs
parentCleanup. (diff)
downloadgentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.tar.gz
gentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.tar.bz2
gentoo-2-14c988d01f8c84ab2bd2faa3c01c646602dc1692.zip
Version bump KDE SC 4.12.1
(Portage version: 2.2.8/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog8
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.12.1.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index aa10439da1b4..4e1420afc7cc 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.237 2014/01/10 04:31:41 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.238 2014/01/18 11:23:47 dilfridge Exp $
+
+*kdepimlibs-4.12.1 (18 Jan 2014)
+
+ 18 Jan 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kdepimlibs-4.12.1.ebuild:
+ Version bump KDE SC 4.12.1
10 Jan 2014; Chris Reffett <creffett@gentoo.org> -kdepimlibs-4.11.4.ebuild:
Remove KDE SC 4.11.4
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.12.1.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.12.1.ebuild
new file mode 100644
index 000000000000..8d3d6cf13815
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.12.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.12.1.ebuild,v 1.1 2014/01/18 11:23:47 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="debug ldap prison"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ !kde-misc/akonadi-social-utils
+ $(add_kdebase_dep nepomuk-core)
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ >=app-crypt/gpgme-1.1.6
+ >=app-office/akonadi-server-1.10.43
+ >=dev-libs/boost-1.35.0-r5:=
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ >=dev-libs/qjson-0.8.1
+ media-libs/phonon
+ x11-misc/shared-mime-info
+ prison? ( media-libs/prison )
+ ldap? ( net-nds/openldap )
+"
+# boost is not linked to, but headers which include it are installed
+# bug #418071
+RDEPEND="${DEPEND}
+ !=kde-base/kdepim-runtime-4.10*
+ !=kde-base/kdepim-runtime-4.11*
+ !<kde-base/kdepim-runtime-4.4.11.1-r2
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.9.1-boostincludes.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_find_package ldap)
+ $(cmake-utils_use_find_package prison)
+ )
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+ rm "${ED}"/usr/share/apps/cmake/modules/FindQJSON.cmake
+ rm "${ED}"/usr/share/apps/cmake/modules/FindQtOAuth.cmake #Collides with net-im/choqok
+}