summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 14:27:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 14:27:55 +0000
commit748b465c6058bf2f9f3095e5b821ede1f0103f64 (patch)
tree07b7f24adbb5691d271199006f0d1d02e11ef0b9 /kde-base/kdepim/kdepim-3.5.5.ebuild
parentBump to 3.5.5 (pre-release) (diff)
downloadgentoo-2-748b465c6058bf2f9f3095e5b821ede1f0103f64.tar.gz
gentoo-2-748b465c6058bf2f9f3095e5b821ede1f0103f64.tar.bz2
gentoo-2-748b465c6058bf2f9f3095e5b821ede1f0103f64.zip
Bump to 3.5.5 (pre-release)
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'kde-base/kdepim/kdepim-3.5.5.ebuild')
-rw-r--r--kde-base/kdepim/kdepim-3.5.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/kdepim/kdepim-3.5.5.ebuild b/kde-base/kdepim/kdepim-3.5.5.ebuild
new file mode 100644
index 000000000000..ad614e377db2
--- /dev/null
+++ b/kde-base/kdepim/kdepim-3.5.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.5.5.ebuild,v 1.1 2006/10/03 14:27:55 flameeyes Exp $
+
+inherit kde-dist
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdepim-3.5-patchset-02.tar.bz2"
+
+DESCRIPTION="KDE PIM (Personal Information Management) apps: korganizer, kmail, knode..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt gnokii pda"
+
+DEPEND="~kde-base/kdebase-${PV}
+ >=dev-libs/cyrus-sasl-2
+ pda? ( app-pda/pilot-link dev-libs/libmal )
+ gnokii? ( app-mobilephone/gnokii )
+ crypt? ( >=app-crypt/gpgme-1.1.2-r1
+ <app-crypt/gnupg-1.9 )"
+ # We use GnuPG 1.4.x for OpenPGP and 1.9 (via gpgme) for s/mime as upstream advises.
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/pinentry )"
+
+src_unpack() {
+ kde_src_unpack
+ # Call Qt 3 designer
+ sed -i -e "s:\"designer\":\"${QTDIR}/bin/designer\":g" ${S}/libkdepim/kcmdesignerfields.cpp || die "sed failed"
+}
+
+src_compile() {
+ local myconf="--with-sasl $(use_with gnokii)"
+ use crypt && myconf="${myconf} --with-gpg=${ROOT}/usr/bin/gpg"
+
+ kde_src_compile
+}