summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
commitb9d227823671a4217d7d0f9e194c5108eacc548e (patch)
tree8d57d37d8c5552901a88ade2d47df6941892d5aa /kde-base/kdepim-l10n
parentStable for HPPA (bug #444546). (diff)
downloadgentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.tar.gz
gentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.tar.bz2
gentoo-2-b9d227823671a4217d7d0f9e194c5108eacc548e.zip
[kde-base] Add KDE SC 4.9.4
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/kdepim-l10n')
-rw-r--r--kde-base/kdepim-l10n/ChangeLog7
-rw-r--r--kde-base/kdepim-l10n/kdepim-l10n-4.9.4.ebuild110
2 files changed, 116 insertions, 1 deletions
diff --git a/kde-base/kdepim-l10n/ChangeLog b/kde-base/kdepim-l10n/ChangeLog
index 603fbc0bf851..9551e2e48a14 100644
--- a/kde-base/kdepim-l10n/ChangeLog
+++ b/kde-base/kdepim-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepim-l10n
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/ChangeLog,v 1.62 2012/11/30 15:45:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/ChangeLog,v 1.63 2012/12/05 16:58:18 alexxy Exp $
+
+*kdepim-l10n-4.9.4 (05 Dec 2012)
+
+ 05 Dec 2012; Alexey Shvetsov <alexxy@gentoo.org> +kdepim-l10n-4.9.4.ebuild:
+ Version bump KDE SC 4.9.4
30 Nov 2012; <ago@gentoo.org> kdepim-l10n-4.9.3.ebuild:
Stable for ppc, wrt bug #442394
diff --git a/kde-base/kdepim-l10n/kdepim-l10n-4.9.4.ebuild b/kde-base/kdepim-l10n/kdepim-l10n-4.9.4.ebuild
new file mode 100644
index 000000000000..67b142769e74
--- /dev/null
+++ b/kde-base/kdepim-l10n/kdepim-l10n-4.9.4.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/kdepim-l10n-4.9.4.ebuild,v 1.1 2012/12/05 16:58:18 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK=optional
+inherit kde4-base
+
+DESCRIPTION="KDE PIM internationalization package"
+
+DEPEND="
+ sys-devel/gettext
+"
+RDEPEND=""
+
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+MY_LANGS="ar bg bs ca ca@valencia cs da de el en_GB es et eu fa fi fr ga gl he
+hi hr hu ia is it ja kk km ko lt lv nb nds nl nn pa pl pt pt_BR ro ru si sk sl
+sr sv tg th tr ug uk vi wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE/kdepim/kde}/kde-l10n-${MY_LANG}-${PV}.tar.xz )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ # For EAPI >= 3, or if not using .tar.xz archives:
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="kde-l10n-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+
+ # remove everything except kdepim and kdepim-runtime
+ for SUBDIR in data docs messages scripts ; do
+ if [[ -d "${S}/${DIR}/${SUBDIR}" ]] ; then
+ einfo " ${SUBDIR} subdirectory"
+ echo > "${S}/${DIR}/${SUBDIR}/CMakeLists.txt"
+ [[ -d "${S}/${DIR}/${SUBDIR}/kdepim" ]] && ( echo "add_subdirectory(kdepim)" >> "${S}/${DIR}/${SUBDIR}/CMakeLists.txt" )
+ [[ -d "${S}/${DIR}/${SUBDIR}/kdepim-runtime" ]] && ( echo "add_subdirectory(kdepim-runtime)" >> "${S}/${DIR}/${SUBDIR}/CMakeLists.txt" )
+ fi
+ done
+
+ # in some cases we may have sub-lingua subdirs, e.g. sr :(
+ for XSUBDIR in "${S}/${DIR}/${LNG}"@* ; do
+ XLNG=$(echo ${XSUBDIR}|sed -e 's:^.*/::')
+ if [[ -d "${XSUBDIR}" ]] ; then
+ einfo " ${XLNG} variant"
+ # remove everything except kdepim and kdepim-runtime
+ for SUBDIR in data docs messages scripts ; do
+ if [[ -d "${XSUBDIR}/${SUBDIR}" ]] ; then
+ einfo " ${SUBDIR} subdirectory"
+ echo > "${XSUBDIR}/${SUBDIR}/CMakeLists.txt"
+ [[ -d "${XSUBDIR}/${SUBDIR}/kdepim" ]] && ( echo "add_subdirectory(kdepim)" >> "${XSUBDIR}/${SUBDIR}/CMakeLists.txt" )
+ [[ -d "${XSUBDIR}/${SUBDIR}/kdepim-runtime" ]] && ( echo "add_subdirectory(kdepim-runtime)" >> "${XSUBDIR}/${SUBDIR}/CMakeLists.txt" )
+ fi
+ done
+ fi
+ done
+ done
+ fi
+}
+
+src_prepare() {
+ [[ -n ${A} ]] && kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook docs)
+ )
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -n ${A} ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}