summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
commitaa3564c24799d7ef9148aa35aa2294090c7d0672 (patch)
tree564f76c48c05f07f04c01e801b11d91042e6830f /kde-base/kdepim-l10n
parentAdd 3.0 documentation (diff)
downloadgentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.tar.gz
gentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.tar.bz2
gentoo-2-aa3564c24799d7ef9148aa35aa2294090c7d0672.zip
[kde-base] Add long waiting KDE SC 4.7.4
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdepim-l10n')
-rw-r--r--kde-base/kdepim-l10n/ChangeLog7
-rw-r--r--kde-base/kdepim-l10n/kdepim-l10n-4.7.4.ebuild109
2 files changed, 115 insertions, 1 deletions
diff --git a/kde-base/kdepim-l10n/ChangeLog b/kde-base/kdepim-l10n/ChangeLog
index 06684ccd8281..98cd475d4bed 100644
--- a/kde-base/kdepim-l10n/ChangeLog
+++ b/kde-base/kdepim-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepim-l10n
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/ChangeLog,v 1.20 2011/12/07 23:07:34 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/ChangeLog,v 1.21 2011/12/11 18:52:35 alexxy Exp $
+
+*kdepim-l10n-4.7.4 (11 Dec 2011)
+
+ 11 Dec 2011; Alexey Shvetsov <alexxy@gentoo.org> +kdepim-l10n-4.7.4.ebuild:
+ Version bump KDE SC 4.7.4
07 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-kdepim-l10n-4.7.2.ebuild:
diff --git a/kde-base/kdepim-l10n/kdepim-l10n-4.7.4.ebuild b/kde-base/kdepim-l10n/kdepim-l10n-4.7.4.ebuild
new file mode 100644
index 000000000000..8b3b5325d663
--- /dev/null
+++ b/kde-base/kdepim-l10n/kdepim-l10n-4.7.4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/kdepim-l10n-4.7.4.ebuild,v 1.1 2011/12/11 18:52:35 alexxy Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="KDE PIM internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="
+ sys-devel/gettext
+"
+RDEPEND=""
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+handbook"
+
+MY_LANGS="ar bg bs ca ca@valencia cs da de el en_GB es et eu fi fr ga gl he hr
+hu ia id is it ja kk km kn ko lt lv nb nds nl nn pa pl pt pt_BR ro ru si sk sl
+sr sv th tr ug uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/kde-l10n-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ # For EAPI >= 3, or if not using .tar.xz archives:
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="kde-l10n-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+
+ # remove everything except kdepim
+ for SUBDIR in data docs messages scripts ; do
+ if [[ -d "${S}/${DIR}/${SUBDIR}" ]] ; then
+ einfo " ${SUBDIR} subdirectory"
+ echo > "${S}/${DIR}/${SUBDIR}/CMakeLists.txt"
+ [[ -d "${S}/${DIR}/${SUBDIR}/kdepim" ]] && ( echo "add_subdirectory(kdepim)" >> "${S}/${DIR}/${SUBDIR}/CMakeLists.txt" )
+ fi
+ done
+
+ # in some cases we may have sub-lingua subdirs, e.g. sr :(
+ for XSUBDIR in "${S}/${DIR}/${LNG}"@* ; do
+ XLNG=$(echo ${XSUBDIR}|sed -e 's:^.*/::')
+ if [[ -d "${XSUBDIR}" ]] ; then
+ einfo " ${XLNG} variant"
+ # remove everything except kdepim
+ for SUBDIR in data docs messages scripts ; do
+ if [[ -d "${XSUBDIR}/${SUBDIR}" ]] ; then
+ einfo " ${SUBDIR} subdirectory"
+ echo > "${XSUBDIR}/${SUBDIR}/CMakeLists.txt"
+ [[ -d "${XSUBDIR}/${SUBDIR}/kdepim" ]] && ( echo "add_subdirectory(kdepim)" >> "${XSUBDIR}/${SUBDIR}/CMakeLists.txt" )
+ fi
+ done
+ fi
+ done
+ done
+ fi
+}
+
+src_prepare() {
+ [[ -n ${A} ]] && kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook docs)
+ )
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -n ${A} ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}