summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
commitb0cf2ebbfc7626d65b374788654d4e26028bda3f (patch)
tree473933e2eaf30d14938b24846be4b834a0d385d4 /kde-base/kdepasswd
parentrename check_apache_threads to has_apache_threads as suggested by dberkholz (diff)
downloadgentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.gz
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.bz2
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.zip
Version bump to KDE 4.0.1.
(Portage version: 2.1.4.1)
Diffstat (limited to 'kde-base/kdepasswd')
-rw-r--r--kde-base/kdepasswd/ChangeLog8
-rw-r--r--kde-base/kdepasswd/files/kdepasswd-4.0.1-linkage.patch13
-rw-r--r--kde-base/kdepasswd/kdepasswd-4.0.1.ebuild20
3 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/kdepasswd/ChangeLog b/kde-base/kdepasswd/ChangeLog
index 81a04010b7a8..e3452ea5db09 100644
--- a/kde-base/kdepasswd/ChangeLog
+++ b/kde-base/kdepasswd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepasswd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepasswd/ChangeLog,v 1.84 2008/01/31 15:31:00 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepasswd/ChangeLog,v 1.85 2008/02/07 00:11:49 philantrop Exp $
+
+*kdepasswd-4.0.1 (06 Feb 2008)
+
+ 06 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kdepasswd-4.0.1-linkage.patch, +kdepasswd-4.0.1.ebuild:
+ Version bump to KDE 4.0.1.
31 Jan 2008; Brent Baude <ranger@gentoo.org> kdepasswd-3.5.8.ebuild:
Marking kdepasswd-3.5.8 ppc for bug 207634
diff --git a/kde-base/kdepasswd/files/kdepasswd-4.0.1-linkage.patch b/kde-base/kdepasswd/files/kdepasswd-4.0.1-linkage.patch
new file mode 100644
index 000000000000..1156e1aeac90
--- /dev/null
+++ b/kde-base/kdepasswd/files/kdepasswd-4.0.1-linkage.patch
@@ -0,0 +1,13 @@
+diff --git a/kdebase/apps/kdepasswd/kcm/CMakeLists.txt b/kdebase/apps/kdepasswd/kcm/CMakeLists.txt
+index e34b684..a1fdcd1 100644
+--- a/kdebase/apps/kdepasswd/kcm/CMakeLists.txt
++++ b/kdebase/apps/kdepasswd/kcm/CMakeLists.txt
+@@ -13,7 +13,7 @@ kde4_add_kcfg_files(kcm_useraccount_PART_SRCS settings.kcfgc)
+
+ kde4_add_plugin(kcm_useraccount ${kcm_useraccount_PART_SRCS})
+
+-target_link_libraries(kcm_useraccount konq ${KDE4_KDESU_LIBS})
++target_link_libraries(kcm_useraccount konq ${KDE4_KPARTS_LIBS} ${KDE4_KDESU_LIBS})
+
+ install(TARGETS kcm_useraccount DESTINATION ${PLUGIN_INSTALL_DIR})
+ install(FILES kcm_useraccount.desktop DESTINATION ${SERVICES_INSTALL_DIR})
diff --git a/kde-base/kdepasswd/kdepasswd-4.0.1.ebuild b/kde-base/kdepasswd/kdepasswd-4.0.1.ebuild
new file mode 100644
index 000000000000..968629cb5863
--- /dev/null
+++ b/kde-base/kdepasswd/kdepasswd-4.0.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepasswd/kdepasswd-4.0.1.ebuild,v 1.1 2008/02/07 00:11:49 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase
+KMMODULE=apps/${PN}
+
+inherit kde4-meta
+
+DESCRIPTION="KDE GUI for passwd"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=kde-base/libkonq-${PV}:${SLOT}"
+RDEPEND="${DEPEND}
+ >=kde-base/kdesu-${PV}:${SLOT}"
+
+PATCHES="${FILESDIR}/${P}-linkage.patch"