summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-11-18 13:43:11 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-11-18 13:43:11 +0000
commit544f26f4ffaacbb7dfba8fd76876a2a8b7a518dc (patch)
tree3dab6868e7f023f1e1e3603a4578e4476895fe85 /kde-base/kdepasswd
parentCleanup unused patches. (diff)
downloadgentoo-2-544f26f4ffaacbb7dfba8fd76876a2a8b7a518dc.tar.gz
gentoo-2-544f26f4ffaacbb7dfba8fd76876a2a8b7a518dc.tar.bz2
gentoo-2-544f26f4ffaacbb7dfba8fd76876a2a8b7a518dc.zip
Cleanup unused patches.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'kde-base/kdepasswd')
-rw-r--r--kde-base/kdepasswd/ChangeLog6
-rw-r--r--kde-base/kdepasswd/files/kdepasswd-4.13.3-use-accountsservice.patch104
2 files changed, 5 insertions, 105 deletions
diff --git a/kde-base/kdepasswd/ChangeLog b/kde-base/kdepasswd/ChangeLog
index 50da32ac20c0..42ef893e94be 100644
--- a/kde-base/kdepasswd/ChangeLog
+++ b/kde-base/kdepasswd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdepasswd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepasswd/ChangeLog,v 1.333 2014/11/16 12:21:22 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepasswd/ChangeLog,v 1.334 2014/11/18 13:43:11 mrueg Exp $
+
+ 18 Nov 2014; Manuel Rüger <mrueg@gentoo.org>
+ -files/kdepasswd-4.13.3-use-accountsservice.patch:
+ Cleanup unused patches.
*kdepasswd-4.14.3 (16 Nov 2014)
diff --git a/kde-base/kdepasswd/files/kdepasswd-4.13.3-use-accountsservice.patch b/kde-base/kdepasswd/files/kdepasswd-4.13.3-use-accountsservice.patch
deleted file mode 100644
index 5a89d4d809db..000000000000
--- a/kde-base/kdepasswd/files/kdepasswd-4.13.3-use-accountsservice.patch
+++ /dev/null
@@ -1,104 +0,0 @@
-Use accountsservice instead of calling chfn directly.
-
-This avoids a potential error or crash when changing user account information.
-Backported 77275f50241eb2f4e38051152074c379fa96fe84 and
-23bbe79912ec21ded8fdfc595935f48a6d2298ea from Plasma 5.
-
-Gentoo bug #380899
-KDE bug #156396
-
---- a/kdepasswd/kcm/CMakeLists.txt
-+++ b/kdepasswd/kcm/CMakeLists.txt
-@@ -1,7 +1,6 @@
- add_subdirectory(pics)
-
- set(kcm_useraccount_PART_SRCS
-- chfnprocess.cpp
- main.cpp
- chfacedlg.cpp)
-
---- a/kdepasswd/kcm/main.cpp
-+++ b/kdepasswd/kcm/main.cpp
-@@ -49,7 +49,6 @@
-
- #include "settings.h"
- #include "pass.h"
--#include "chfnprocess.h"
- #include <KPluginFactory>
- #include <KPluginLoader>
-
-@@ -181,36 +180,27 @@ void KCMUserAccount::save()
- /* Save realname to /etc/passwd */
- if ( _mw->leRealname->isModified() )
- {
-- KPasswordDialog dlg( _mw );
-- dlg.setPrompt(i18n("Please enter your password in order to save your settings:"));
-- if ( !dlg.exec() )
-- {
-- KMessageBox::sorry( this, i18n("You must enter "
-- "your password in order to change your information."));
-- return;
-- }
--
-- ChfnProcess *proc = new ChfnProcess();
-- int ret = proc->exec(dlg.password().toLocal8Bit() , _mw->leRealname->text().toLocal8Bit() );
-- if ( ret )
-- {
-- if ( ret == ChfnProcess::PasswordError )
-- KMessageBox::sorry( this, i18n("You must enter a correct password."));
--
-- else
-- {
-- KMessageBox::sorry( this, i18n("An error occurred and your name has "
-- "probably not been changed. The error "
-- "message was:\n%1", QString::fromLocal8Bit(proc->error())));
-- kDebug() << "ChfnProcess->exec() failed. Error code: " << ret
-- << "\nOutput:" << proc->error() << endl;
-- }
--
-- delete proc;
-- return;
-- }
--
-- delete proc;
-+ // save icon file also with accountsservice
-+ QDBusInterface ainterface("org.freedesktop.Accounts",
-+ "/org/freedesktop/Accounts",
-+ "org.freedesktop.Accounts",
-+ QDBusConnection::systemBus());
-+ QDBusReply<QDBusObjectPath> reply = ainterface.call("FindUserById", qlonglong(_ku->uid()));
-+ if (reply.isValid() && !reply.error().isValid()) {
-+ QDBusInterface uinterface("org.freedesktop.Accounts",
-+ reply.value().path(),
-+ "org.freedesktop.Accounts.User",
-+ QDBusConnection::systemBus(),
-+ this);
-+
-+ QString name = _mw->leRealname->text();
-+ QDBusReply<void> ureply = uinterface.call("SetRealName", name);
-+ if (!ureply.isValid() || ureply.error().isValid()) {
-+ kDebug() << ureply.error().message();
-+ KMessageBox::error( this, i18n("There was an error setting the name: %1" ,
-+ name) );
-+ }
-+ }
- }
- #endif
-
-@@ -243,10 +233,12 @@ void KCMUserAccount::save()
- }
- }
- else { // delete existing image
-- if ( !KIO::NetAccess::del(KCFGUserAccount::faceFile(), this) ) {
-- KMessageBox::error( this, i18n("There was an error deleting the image: %1" ,
-- KCFGUserAccount::faceFile()) );
-- }
-+ if (QFile::exists(KCFGUserAccount::faceFile())) {
-+ if ( !KIO::NetAccess::del(KCFGUserAccount::faceFile(), this) ) {
-+ KMessageBox::error( this, i18n("There was an error deleting the image: %1" ,
-+ KCFGUserAccount::faceFile()) );
-+ }
-+ }
- }
-
- /* Save KDE's homebrewn settings */ \ No newline at end of file