summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-19 22:29:38 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-19 22:29:38 +0000
commit250208a5b49f56c163484a9f0a9be177a9742eda (patch)
tree3d926a7ffd9d24a83c9e03ac22f20800c5286713 /kde-base/kdemultimedia
parentVersion bump (diff)
downloadgentoo-2-250208a5b49f56c163484a9f0a9be177a9742eda.tar.gz
gentoo-2-250208a5b49f56c163484a9f0a9be177a9742eda.tar.bz2
gentoo-2-250208a5b49f56c163484a9f0a9be177a9742eda.zip
Bump to KDE 3.5.8.
(Portage version: 2.1.3.15)
Diffstat (limited to 'kde-base/kdemultimedia')
-rw-r--r--kde-base/kdemultimedia/ChangeLog8
-rw-r--r--kde-base/kdemultimedia/files/digest-kdemultimedia-3.5.83
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.5.8.ebuild97
3 files changed, 107 insertions, 1 deletions
diff --git a/kde-base/kdemultimedia/ChangeLog b/kde-base/kdemultimedia/ChangeLog
index a118e12ff4e4..8e38854c72fa 100644
--- a/kde-base/kdemultimedia/ChangeLog
+++ b/kde-base/kdemultimedia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdemultimedia
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/ChangeLog,v 1.255 2007/10/03 01:27:39 redhatter Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/ChangeLog,v 1.256 2007/10/19 22:29:37 philantrop Exp $
+
+*kdemultimedia-3.5.8 (19 Oct 2007)
+
+ 19 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdemultimedia-3.5.8.ebuild:
+ Bump to KDE 3.5.8.
02 Oct 2007; Stuart Longland <redhatter@gentoo.org>
kdemultimedia-3.5.7.ebuild:
diff --git a/kde-base/kdemultimedia/files/digest-kdemultimedia-3.5.8 b/kde-base/kdemultimedia/files/digest-kdemultimedia-3.5.8
new file mode 100644
index 000000000000..8038f4ee451d
--- /dev/null
+++ b/kde-base/kdemultimedia/files/digest-kdemultimedia-3.5.8
@@ -0,0 +1,3 @@
+MD5 9f3c95231ea265b09f3010adb954ae30 kdemultimedia-3.5.8.tar.bz2 6316739
+RMD160 5fcb8d282e2d49baca4daa9fb4e24b5216df92ee kdemultimedia-3.5.8.tar.bz2 6316739
+SHA256 07fc79e38bd7d50a8e2b9910a5d78ef565557b2a746b31d5d440829e9f05b0c1 kdemultimedia-3.5.8.tar.bz2 6316739
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.5.8.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.5.8.ebuild
new file mode 100644
index 000000000000..6fc53b19aa6f
--- /dev/null
+++ b/kde-base/kdemultimedia/kdemultimedia-3.5.8.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.5.8.ebuild,v 1.1 2007/10/19 22:29:37 philantrop Exp $
+
+inherit kde-dist flag-o-matic
+
+DESCRIPTION="KDE multimedia apps: Noatun, KsCD, Juk..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="akode alsa audiofile encode flac gstreamer mp3 theora vorbis xine"
+
+DEPEND="media-sound/cdparanoia
+ akode? ( media-libs/akode )
+ >=media-libs/taglib-1.2
+ audiofile? ( media-libs/audiofile )
+ xine? ( >=media-libs/xine-lib-1.0 )
+ alsa? ( media-libs/alsa-lib )
+ theora? (
+ media-libs/libvorbis
+ media-libs/libtheora )
+ gstreamer? ( =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-base-0.10* )
+ encode? ( mp3? ( media-sound/lame )
+ vorbis? ( media-sound/vorbis-tools )
+ flac? ( >=media-libs/flac-1.1.2 ) )
+ !arts? ( !gstreamer? ( media-libs/akode ) )"
+
+RDEPEND="${DEPEND}
+ gstreamer? ( mp3? ( =media-plugins/gst-plugins-mad-0.10* )
+ vorbis? ( =media-plugins/gst-plugins-ogg-0.10*
+ =media-plugins/gst-plugins-vorbis-0.10* )
+ flac? ( =media-plugins/gst-plugins-flac-0.10* ) )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+PATCHES="${FILESDIR}/kdemultimedia-3.5.5+flac-1.1.3.patch"
+
+pkg_setup() {
+ kde_pkg_setup
+ if ! use arts && ! use gstreamer && ! use akode ; then
+ ewarn "No audio backend chosen. Defaulting to media-libs/akode."
+ fi
+}
+
+src_compile() {
+ local myconf="--with-cdparanoia
+ --with-taglib
+ --with-akode
+ $(use_with alsa)
+ $(use_with audiofile)
+ $(use_with gstreamer)
+ $(use_with xine)
+ $(use_with theora)
+ --without-musicbrainz"
+
+ # encoding can happen through:
+ # - kio_audiocd (based on libflac for flac,
+ # on libvorbis for vorbis, on the lame binary for mp3)
+ # - kaudiocreator (based on the flac binary for flac,
+ # on the lame binary for mp3, on the oggenc binary for vorbis)
+ # - krec (based on libvorbis for vorbis,
+ # on libmp3lame for mp3)
+ if use encode; then
+ myconf="${myconf}
+ $(use_with mp3 lame)
+ $(use_with vorbis)
+ $(use_with flac)"
+ else
+ myconf="${myconf}
+ --without-lame
+ --without-vorbis
+ --without-flac"
+ fi
+
+ if ! use arts && ! use gstreamer ; then
+ myconf="${myconf} --with-akokde"
+ else
+ if ! use akode ; then
+ # work around broken configure
+ export include_akode_ffmpeg_FALSE='#'
+ export include_akode_mpc_FALSE='#'
+ export include_akode_mpeg_FALSE='#'
+ export include_akode_xiph_FALSE='#'
+ fi
+ myconf="${myconf} $(use_with akode)"
+ fi
+
+ # fix bug 128884
+ filter-flags -fomit-frame-pointer
+
+ # Not used anymore and scheduled for removal.
+ export DO_NOT_COMPILE="${DO_NOT_COMPILE} mpeglib mpeglib_artsplug"
+
+ rm configure
+ kde_src_compile
+}