summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoannis Aslanidis <deathwing00@gentoo.org>2006-10-11 09:59:54 +0000
committerIoannis Aslanidis <deathwing00@gentoo.org>2006-10-11 09:59:54 +0000
commit9918656274e899acc7906e411b0b3fb7f1a9a0f6 (patch)
tree7de025ae35d80ca305839dc4040c889d23830c17 /kde-base/kdelibs
parentversion bump thanks to Bret Towe in irc (diff)
downloadgentoo-2-9918656274e899acc7906e411b0b3fb7f1a9a0f6.tar.gz
gentoo-2-9918656274e899acc7906e411b0b3fb7f1a9a0f6.tar.bz2
gentoo-2-9918656274e899acc7906e411b0b3fb7f1a9a0f6.zip
Added a patch to fix small issues on the kate component for kdelibs-3.5.5.
(Portage version: 2.1.1)
Diffstat (limited to 'kde-base/kdelibs')
-rw-r--r--kde-base/kdelibs/ChangeLog6
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.5-kate-cstyle-indenter-fix.diff45
-rw-r--r--kde-base/kdelibs/kdelibs-3.5.5.ebuild8
3 files changed, 57 insertions, 2 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index 2c0dbb529b9f..627dbd33b9cd 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.366 2006/10/07 15:06:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.367 2006/10/11 09:59:54 deathwing00 Exp $
+
+ 11 Oct 2006; Ioannis Aslanidis <deathwing00@gentoo.org>
+ +files/kdelibs-3.5.5-kate-cstyle-indenter-fix.diff, kdelibs-3.5.5.ebuild:
+ Added a patch that fixes a nasty regression in the cstyle identifier of kate.
07 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
files/digest-kdelibs-3.5.5, Manifest:
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.5-kate-cstyle-indenter-fix.diff b/kde-base/kdelibs/files/kdelibs-3.5.5-kate-cstyle-indenter-fix.diff
new file mode 100644
index 000000000000..c7697a9ad8d4
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-3.5.5-kate-cstyle-indenter-fix.diff
@@ -0,0 +1,45 @@
+diff -U 4 -H -b -w -B -E -d -i -r kdelibs-3.5.5-orig/kate/part/kateautoindent.cpp kdelibs-3.5.5/kate/part/kateautoindent.cpp
+--- kdelibs-3.5.5-orig/kate/part/kateautoindent.cpp 2006-10-11 11:44:37.000000000 +0200
++++ kdelibs-3.5.5/kate/part/kateautoindent.cpp 2006-10-11 11:47:38.000000000 +0200
+@@ -713,8 +713,9 @@
+ int anchorPos = 0;
+ int parenCount = 0; // Possibly in a multiline for stmt. Used to skip ';' ...
+ bool found = false;
+ bool isSpecial = false;
++ bool potentialAnchorSeen = false;
+
+ //kdDebug(13030) << "calcIndent begin line:" << begin.line() << " col:" << begin.col() << endl;
+
+ // Find Indent Anchor Point
+@@ -732,18 +733,18 @@
+ if (textLine->attribute(pos) == symbolAttrib)
+ {
+ QChar tc = textLine->getChar (pos);
+ if ((tc == ';' || tc == ':' || tc == ',') && otherAnchor == -1 && parenCount <= 0)
+- otherAnchor = pos;
++ otherAnchor = pos, potentialAnchorSeen = true;
+ else if (tc == ')')
+ parenCount++;
+ else if (tc == '(')
+ parenCount--;
+ else if (tc == '}')
+ openCount--;
+ else if (tc == '{')
+ {
+- openCount++;
++ openCount++, potentialAnchorSeen = true;
+ if (openCount == 1)
+ break;
+ }
+ }
+@@ -825,9 +826,9 @@
+ }
+ }
+
+ // treat beginning of document as anchor position
+- if (cur.line() == 0 && cur.col() == 0)
++ if (cur.line() == 0 && cur.col() == 0 && potentialAnchorSeen)
+ found = true;
+
+ if (!found)
+ return 0;
diff --git a/kde-base/kdelibs/kdelibs-3.5.5.ebuild b/kde-base/kdelibs/kdelibs-3.5.5.ebuild
index 5a6d05491bcb..857a59ae0f7c 100644
--- a/kde-base/kdelibs/kdelibs-3.5.5.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.5.ebuild,v 1.2 2006/10/03 23:09:07 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.5.ebuild,v 1.3 2006/10/11 09:59:54 deathwing00 Exp $
inherit kde flag-o-matic eutils multilib
set-kdedir 3.5
@@ -83,6 +83,12 @@ src_unpack() {
# TODO - kspell2 Xspell plugins are automagically detected.
# As nothing uses kspell2, don't install them.
sed -i -e "s:plugins::" "${S}/kspell2/Makefile.am" || die "sed failed"
+
+ # Apply the following patch on the next revision of kdelibs-3.5.5 (fixes kde
+ # bug #135409), which corrects a nasty regression in the cstyle indenter.
+ # Revision bump was not forced for this patch. If users want it before the
+ # next revision bump, they should simply reemerge kdelibs.
+ epatch "${FILESDIR}/${P}-kate-cstyle-indenter-fix.diff"
}
src_compile() {