summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-01 19:08:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-01 19:08:34 +0000
commit87f659ccfa7b8fd6d1c08666f43d11a4382681a8 (patch)
tree73928b16aae308e5989efbd8e428b0a4845685d0 /kde-base/kdelibs
parentMake support for hidden visibility explicit. (diff)
downloadgentoo-2-87f659ccfa7b8fd6d1c08666f43d11a4382681a8.tar.gz
gentoo-2-87f659ccfa7b8fd6d1c08666f43d11a4382681a8.tar.bz2
gentoo-2-87f659ccfa7b8fd6d1c08666f43d11a4382681a8.zip
Make support for hidden visibility explicit.
(Portage version: 2.1.2_rc2-r3)
Diffstat (limited to 'kde-base/kdelibs')
-rw-r--r--kde-base/kdelibs/ChangeLog7
-rw-r--r--kde-base/kdelibs/kdelibs-3.5.2-r6.ebuild22
-rw-r--r--kde-base/kdelibs/kdelibs-3.5.5-r4.ebuild6
-rw-r--r--kde-base/kdelibs/kdelibs-3.5.5-r5.ebuild6
-rw-r--r--kde-base/kdelibs/kdelibs-3.5.5-r6.ebuild6
-rw-r--r--kde-base/kdelibs/kdelibs-3.5.5-r7.ebuild6
6 files changed, 29 insertions, 24 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index f958dc044081..65a18bcf3686 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.397 2006/11/26 14:35:30 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.398 2006/12/01 19:08:34 flameeyes Exp $
+
+ 01 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+ kdelibs-3.5.2-r6.ebuild, kdelibs-3.5.5-r4.ebuild, kdelibs-3.5.5-r5.ebuild,
+ kdelibs-3.5.5-r6.ebuild, kdelibs-3.5.5-r7.ebuild:
+ Make support for hidden visibility explicit.
26 Nov 2006; Markus Rothe <corsair@gentoo.org> kdelibs-3.5.5-r5.ebuild:
Stable on ppc64
diff --git a/kde-base/kdelibs/kdelibs-3.5.2-r6.ebuild b/kde-base/kdelibs/kdelibs-3.5.2-r6.ebuild
index bb742e116998..f0d804759b41 100644
--- a/kde-base/kdelibs/kdelibs-3.5.2-r6.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.5.2-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.2-r6.ebuild,v 1.18 2006/11/19 17:55:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.2-r6.ebuild,v 1.19 2006/12/01 19:08:34 flameeyes Exp $
inherit kde flag-o-matic eutils multilib
set-kdedir 3.5
@@ -13,7 +13,7 @@ SRC_URI="mirror://kde/stable/${PV}/src/${P}.tar.bz2
LICENSE="GPL-2 LGPL-2"
SLOT="3.5"
KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="acl alsa arts cups doc jpeg2k kerberos legacyssl openexr spell ssl tiff zeroconf"
+IUSE="acl alsa arts cups doc jpeg2k kerberos legacyssl openexr spell ssl tiff zeroconf kdehiddenvisibility"
# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
# so we recreate the entire DEPEND from scratch.
@@ -39,7 +39,7 @@ RDEPEND="$(qt_min_version 3.3.3)
jpeg2k? ( media-libs/jasper )
openexr? ( >=media-libs/openexr-1.2 )
spell? ( || ( ( app-text/aspell app-dicts/aspell-en )
- app-text/ispell ) )
+ app-text/ispell ) )
zeroconf? ( net-misc/mDNSResponder !kde-misc/kdnssd-avahi )
virtual/fam
virtual/ghostscript
@@ -94,14 +94,14 @@ src_compile() {
# and then fails because of missing required functions
myconf="--with-distribution=Gentoo
- --enable-libfam $(use_enable kernel_linux dnotify)
- --with-libart --with-libidn --with-utempter
- $(use_with acl) $(use_with ssl)
- $(use_with alsa) $(use_with arts)
- $(use_with kerberos gssapi) $(use_with tiff)
- $(use_with jpeg2k jasper) $(use_with openexr)
- $(use_enable cups) $(use_enable zeroconf dnssd)
- --without-hspell"
+ --enable-libfam $(use_enable kernel_linux dnotify)
+ --with-libart --with-libidn --with-utempter
+ $(use_with acl) $(use_with ssl)
+ $(use_with alsa) $(use_with arts)
+ $(use_with kerberos gssapi) $(use_with tiff)
+ $(use_with jpeg2k jasper) $(use_with openexr)
+ $(use_enable cups) $(use_enable zeroconf dnssd)
+ --without-hspell"
if use spell && has_version app-text/aspell; then
myconf="${myconf} --with-aspell"
diff --git a/kde-base/kdelibs/kdelibs-3.5.5-r4.ebuild b/kde-base/kdelibs/kdelibs-3.5.5-r4.ebuild
index 8b28bb5335aa..5595c7e1f4e3 100644
--- a/kde-base/kdelibs/kdelibs-3.5.5-r4.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.5.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.5-r4.ebuild,v 1.5 2006/11/19 17:55:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.5-r4.ebuild,v 1.6 2006/12/01 19:08:34 flameeyes Exp $
inherit kde flag-o-matic eutils multilib
set-kdedir 3.5
@@ -14,7 +14,7 @@ LICENSE="GPL-2 LGPL-2"
SLOT="3.5"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="acl alsa arts cups doc jpeg2k kerberos legacyssl utempter openexr spell ssl tiff
-zeroconf kernel_linux fam lua"
+zeroconf kernel_linux fam lua kdehiddenvisibility"
# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
# so we recreate the entire DEPEND from scratch.
@@ -167,7 +167,7 @@ pkg_postinst() {
elog "To make zeroconf support available in KDE make sure that the 'mdnsd' daemon"
elog "is running. Make sure also that multicast dns lookups are enabled by editing"
elog "the 'hosts:' line in /etc/nsswitch.conf to include 'mdns', e.g.:"
- elog " hosts: files mdns dns"
+ elog " hosts: files mdns dns"
echo
fi
}
diff --git a/kde-base/kdelibs/kdelibs-3.5.5-r5.ebuild b/kde-base/kdelibs/kdelibs-3.5.5-r5.ebuild
index 0cd1c8eb05f2..f59f324ff8fb 100644
--- a/kde-base/kdelibs/kdelibs-3.5.5-r5.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.5.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.5-r5.ebuild,v 1.15 2006/11/26 14:35:30 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.5-r5.ebuild,v 1.16 2006/12/01 19:08:34 flameeyes Exp $
inherit kde flag-o-matic eutils multilib
set-kdedir 3.5
@@ -14,7 +14,7 @@ LICENSE="GPL-2 LGPL-2"
SLOT="3.5"
KEYWORDS="~alpha amd64 hppa ~ia64 ~ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="acl alsa arts cups doc jpeg2k kerberos legacyssl utempter openexr spell ssl tiff
-zeroconf kernel_linux fam lua linguas_he"
+zeroconf kernel_linux fam lua linguas_he kdehiddenvisibility"
# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
# so we recreate the entire DEPEND from scratch.
@@ -174,7 +174,7 @@ pkg_postinst() {
elog "To make zeroconf support available in KDE make sure that the 'mdnsd' daemon"
elog "is running. Make sure also that multicast dns lookups are enabled by editing"
elog "the 'hosts:' line in /etc/nsswitch.conf to include 'mdns', e.g.:"
- elog " hosts: files mdns dns"
+ elog " hosts: files mdns dns"
echo
fi
}
diff --git a/kde-base/kdelibs/kdelibs-3.5.5-r6.ebuild b/kde-base/kdelibs/kdelibs-3.5.5-r6.ebuild
index 30eaf4b405c2..5583c4d7c3e1 100644
--- a/kde-base/kdelibs/kdelibs-3.5.5-r6.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.5.5-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.5-r6.ebuild,v 1.7 2006/11/24 21:57:28 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.5-r6.ebuild,v 1.8 2006/12/01 19:08:34 flameeyes Exp $
inherit kde flag-o-matic eutils multilib
set-kdedir 3.5
@@ -14,7 +14,7 @@ LICENSE="GPL-2 LGPL-2"
SLOT="3.5"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="acl alsa arts cups doc jpeg2k kerberos legacyssl utempter openexr spell ssl tiff
-zeroconf avahi kernel_linux fam lua linguas_he"
+zeroconf avahi kernel_linux fam lua linguas_he kdehiddenvisibility"
# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
# so we recreate the entire DEPEND from scratch.
@@ -187,7 +187,7 @@ pkg_postinst() {
elog "To make zeroconf support available in KDE make sure that the 'mdnsd' daemon"
elog "is running. Make sure also that multicast dns lookups are enabled by editing"
elog "the 'hosts:' line in /etc/nsswitch.conf to include 'mdns', e.g.:"
- elog " hosts: files mdns dns"
+ elog " hosts: files mdns dns"
echo
fi
}
diff --git a/kde-base/kdelibs/kdelibs-3.5.5-r7.ebuild b/kde-base/kdelibs/kdelibs-3.5.5-r7.ebuild
index 655d28b682b3..22137f3ff380 100644
--- a/kde-base/kdelibs/kdelibs-3.5.5-r7.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.5.5-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.5-r7.ebuild,v 1.4 2006/11/25 16:49:38 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.5-r7.ebuild,v 1.5 2006/12/01 19:08:34 flameeyes Exp $
inherit kde flag-o-matic eutils multilib
set-kdedir 3.5
@@ -15,7 +15,7 @@ LICENSE="GPL-2 LGPL-2"
SLOT="3.5"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="acl alsa arts cups doc jpeg2k kerberos legacyssl utempter openexr spell ssl tiff
-zeroconf avahi kernel_linux fam lua linguas_he"
+zeroconf avahi kernel_linux fam lua linguas_he kdehiddenvisibility"
# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
# so we recreate the entire DEPEND from scratch.
@@ -192,7 +192,7 @@ pkg_postinst() {
elog "To make zeroconf support available in KDE make sure that the 'mdnsd' daemon"
elog "is running. Make sure also that multicast dns lookups are enabled by editing"
elog "the 'hosts:' line in /etc/nsswitch.conf to include 'mdns', e.g.:"
- elog " hosts: files mdns dns"
+ elog " hosts: files mdns dns"
echo
fi
}