summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-03-14 21:11:40 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-03-14 21:11:40 +0000
commit7a8b37bc94e0beeb7e3508b5d68e6a973368fcea (patch)
tree4fc224813cc9066b5bf7218c4f55e1750fc6ca2b /kde-base/kdelibs/kdelibs-3.4.0.ebuild
parentMarked ~mips (diff)
downloadgentoo-2-7a8b37bc94e0beeb7e3508b5d68e6a973368fcea.tar.gz
gentoo-2-7a8b37bc94e0beeb7e3508b5d68e6a973368fcea.tar.bz2
gentoo-2-7a8b37bc94e0beeb7e3508b5d68e6a973368fcea.zip
Add patch for bug #84500 (freezing in web forms). Readd ~sparc keyword.
(Portage version: 2.0.51.19)
Diffstat (limited to 'kde-base/kdelibs/kdelibs-3.4.0.ebuild')
-rw-r--r--kde-base/kdelibs/kdelibs-3.4.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/kde-base/kdelibs/kdelibs-3.4.0.ebuild b/kde-base/kdelibs/kdelibs-3.4.0.ebuild
index e004cd939824..147e705baf9d 100644
--- a/kde-base/kdelibs/kdelibs-3.4.0.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.4.0.ebuild,v 1.2 2005/03/13 23:23:23 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.4.0.ebuild,v 1.3 2005/03/14 21:11:40 greg_g Exp $
inherit kde eutils
set-kdedir 3.4
@@ -11,7 +11,7 @@ SRC_URI="mirror://kde/stable/3.4/src/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="3.4"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~x86 ~amd64 ~sparc"
IUSE="alsa arts cups doc jpeg2k kerberos openexr spell ssl tiff zeroconf"
# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
@@ -47,6 +47,13 @@ DEPEND="${RDEPEND}
# from branch to work without this patch
#PATCHES="${FILESDIR}/${PN}-3.4.0_beta2-export-kio-symbols.diff"
+src_unpack() {
+ kde_src_unpack
+
+ # Fix freezing in web forms (kde bug 100963). Applied in CVS.
+ epatch "${FILESDIR}/${P}-form-freeze.patch"
+}
+
src_compile() {
myconf="--with-distribution=Gentoo --enable-libfam --enable-dnotify"
myconf="${myconf} $(use_with alsa) $(use_with arts)"