summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
commit2e92514fb34e1f80047f1661e4193fa9a3d3a06c (patch)
treef15f05d59c776fb13bf637e65c070c72f7b65720 /kde-base/kdebindings-ruby
parentFix libpng SLOT depend wrt #339796 by "MaratIK". (diff)
downloadgentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.tar.gz
gentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.tar.bz2
gentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.zip
Add KDE SC 4.5.2 =)
(Portage version: 2.2_rc88_p115/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdebindings-ruby')
-rw-r--r--kde-base/kdebindings-ruby/ChangeLog8
-rw-r--r--kde-base/kdebindings-ruby/kdebindings-ruby-4.5.2.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/kde-base/kdebindings-ruby/ChangeLog b/kde-base/kdebindings-ruby/ChangeLog
index 692811b7b7d9..de6c85845dbb 100644
--- a/kde-base/kdebindings-ruby/ChangeLog
+++ b/kde-base/kdebindings-ruby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebindings-ruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.21 2010/09/15 09:04:04 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.22 2010/10/06 09:17:34 alexxy Exp $
+
+*kdebindings-ruby-4.5.2 (05 Oct 2010)
+
+ 05 Oct 2010; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdebindings-ruby-4.5.2.ebuild:
+ Version bump KDE SC 4.5.2
15 Sep 2010; Maciej Mrozowski <reavertm@gentoo.org>
kdebindings-ruby-4.4.5.ebuild:
diff --git a/kde-base/kdebindings-ruby/kdebindings-ruby-4.5.2.ebuild b/kde-base/kdebindings-ruby/kdebindings-ruby-4.5.2.ebuild
new file mode 100644
index 000000000000..d49f25354aa4
--- /dev/null
+++ b/kde-base/kdebindings-ruby/kdebindings-ruby-4.5.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/kdebindings-ruby-4.5.2.ebuild,v 1.1 2010/10/06 09:17:34 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebindings"
+KMMODULE="ruby"
+WEBKIT_REQUIRED="optional"
+
+USE_RUBY="ruby18"
+# No ruby19 for three reasons:
+# 1) it does not build (yet) - will likely be solved soon
+# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-meta ruby-ng
+
+DESCRIPTION="KDE Ruby bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="akonadi debug okular phonon plasma qscintilla qwt semantic-desktop"
+
+DEPEND="
+ $(add_kdebase_dep smoke 'akonadi?,okular?,phonon?,qscintilla?,qwt?,semantic-desktop?,webkit?')
+"
+RDEPEND="${DEPEND}
+ !dev-ruby/qt4-qtruby
+"
+
+# Merged with kdebindings-ruby after 4.4.80
+add_blocker krossruby
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-meta_pkg_setup
+}
+
+src_unpack() {
+ kde4-meta_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-meta_src_prepare
+
+ sed -i -e "s#smoke/smoke.h#smoke.h#" \
+ ruby/qtruby/src/handlers.cpp \
+ ruby/qtruby/src/marshall.h \
+ ruby/qtruby/src/marshall_types.h \
+ ruby/qtruby/src/Qt.cpp \
+ ruby/qtruby/src/qtruby.cpp \
+ ruby/qtruby/src/qtruby.h \
+ ruby/qtruby/src/smokeruby.h || die
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_with qwt Qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-meta_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR=${S}
+ kde4-meta_src_compile
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR=${S}
+ kde4-meta_src_install
+}