summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 20:54:38 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 20:54:38 +0000
commit5a1fc42253b3d4744182700e5ef34d2e6074e917 (patch)
treeac40971c4344566111c5565e8519b2505c94fb84 /kde-base/kdebase-kioslaves
parentVersion bump to KDE 4.0.3. This is still not intended for mainstream so DO NO... (diff)
downloadgentoo-2-5a1fc42253b3d4744182700e5ef34d2e6074e917.tar.gz
gentoo-2-5a1fc42253b3d4744182700e5ef34d2e6074e917.tar.bz2
gentoo-2-5a1fc42253b3d4744182700e5ef34d2e6074e917.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kdebase-kioslaves')
-rw-r--r--kde-base/kdebase-kioslaves/ChangeLog9
-rw-r--r--kde-base/kdebase-kioslaves/kdebase-kioslaves-4.0.3.ebuild50
2 files changed, 58 insertions, 1 deletions
diff --git a/kde-base/kdebase-kioslaves/ChangeLog b/kde-base/kdebase-kioslaves/ChangeLog
index 0f053e3aee8f..58c829688a15 100644
--- a/kde-base/kdebase-kioslaves/ChangeLog
+++ b/kde-base/kdebase-kioslaves/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kdebase-kioslaves
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase-kioslaves/ChangeLog,v 1.116 2008/03/27 22:25:51 zlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase-kioslaves/ChangeLog,v 1.117 2008/04/03 20:54:38 philantrop Exp $
+
+*kdebase-kioslaves-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdebase-kioslaves-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
27 Mar 2008; Bo Ørsted Andresen <zlin@gentoo.org>
kdebase-kioslaves-4.0.2.ebuild:
diff --git a/kde-base/kdebase-kioslaves/kdebase-kioslaves-4.0.3.ebuild b/kde-base/kdebase-kioslaves/kdebase-kioslaves-4.0.3.ebuild
new file mode 100644
index 000000000000..8aaf2de76b83
--- /dev/null
+++ b/kde-base/kdebase-kioslaves/kdebase-kioslaves-4.0.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase-kioslaves/kdebase-kioslaves-4.0.3.ebuild,v 1.1 2008/04/03 20:54:38 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-runtime
+KMMODULE=kioslave
+inherit kde4-meta
+
+DESCRIPTION="kioslave: the kde VFS framework - kioslave plugins present a filesystem-like view of arbitrary data"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bzip2 debug htmlhandbook openexr samba"
+# 2 out of 2 tests fail. last checked on 4.0.1.
+RESTRICT="test"
+
+# Note that if you upgrade strigi, you have to rebuild this package.
+DEPEND="
+ >=app-misc/strigi-0.5.7
+ >=dev-libs/cyrus-sasl-2
+ >=sys-apps/dbus-1.0.2
+ =sys-apps/hal-0.5*
+ x11-libs/libXcursor
+ samba? ( >=net-fs/samba-3.0.1 )
+ openexr? ( >=media-libs/openexr-1.2.2-r2 )"
+RDEPEND="${DEPEND}
+ >=kde-base/kdesu-${PV}:${SLOT}
+ >=kde-base/kdialog-${PV}:${SLOT}
+ virtual/ssh"
+
+KMEXTRA="
+ kioexec
+ kdeeject"
+
+src_unpack() {
+ if use htmlhandbook; then
+ KMEXTRA="${KMEXTRA}
+ doc/kioslave"
+ fi
+ kde4-meta_src_unpack
+}
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with samba Samba)
+ $(cmake-utils_use_with openexr OpenEXR)"
+
+ kde4-meta_src_compile
+}