summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-04-08 12:27:54 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-04-08 12:27:54 +0000
commit9bd014ea89feec52d3e8451af6a38c405baee975 (patch)
treeceebb5294a6a5f9fde478965f501aee38bc800ad /kde-base/kdeadmin
parentminor formatting fix (Bug #88316) (diff)
downloadgentoo-2-9bd014ea89feec52d3e8451af6a38c405baee975.tar.gz
gentoo-2-9bd014ea89feec52d3e8451af6a38c405baee975.tar.bz2
gentoo-2-9bd014ea89feec52d3e8451af6a38c405baee975.zip
Add patch to fix /etc/passwd corruption in kuser (#87405).
(Portage version: 2.0.51.19)
Diffstat (limited to 'kde-base/kdeadmin')
-rw-r--r--kde-base/kdeadmin/ChangeLog8
-rw-r--r--kde-base/kdeadmin/files/digest-kdeadmin-3.4.0-r11
-rw-r--r--kde-base/kdeadmin/files/kdeadmin-3.4.0-kuser.patch41
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild38
4 files changed, 87 insertions, 1 deletions
diff --git a/kde-base/kdeadmin/ChangeLog b/kde-base/kdeadmin/ChangeLog
index af41815ab965..6510daf94cc5 100644
--- a/kde-base/kdeadmin/ChangeLog
+++ b/kde-base/kdeadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeadmin
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.119 2005/03/18 17:22:51 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.120 2005/04/08 12:27:54 greg_g Exp $
+
+*kdeadmin-3.4.0-r1 (08 Apr 2005)
+
+ 08 Apr 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/kdeadmin-3.4.0-kuser.patch, +kdeadmin-3.4.0-r1.ebuild:
+ Add patch to fix /etc/passwd corruption in kuser (#87405).
18 Mar 2005; Daniel Goller <morfic@gentoo.org> kdeadmin-3.4.0.ebuild:
Added to ~ppc
diff --git a/kde-base/kdeadmin/files/digest-kdeadmin-3.4.0-r1 b/kde-base/kdeadmin/files/digest-kdeadmin-3.4.0-r1
new file mode 100644
index 000000000000..8cbd9915d983
--- /dev/null
+++ b/kde-base/kdeadmin/files/digest-kdeadmin-3.4.0-r1
@@ -0,0 +1 @@
+MD5 d1db9fac4faca194cbda1e8189453363 kdeadmin-3.4.0.tar.bz2 1567785
diff --git a/kde-base/kdeadmin/files/kdeadmin-3.4.0-kuser.patch b/kde-base/kdeadmin/files/kdeadmin-3.4.0-kuser.patch
new file mode 100644
index 000000000000..b73ae0b384e3
--- /dev/null
+++ b/kde-base/kdeadmin/files/kdeadmin-3.4.0-kuser.patch
@@ -0,0 +1,41 @@
+diff -Nur kdeadmin-3.4.0.orig/kuser/propdlg.cpp kdeadmin-3.4.0/kuser/propdlg.cpp
+--- kdeadmin-3.4.0.orig/kuser/propdlg.cpp 2004-11-29 01:03:48.000000000 +0100
++++ kdeadmin-3.4.0/kuser/propdlg.cpp 2005-04-08 14:05:03.000000000 +0200
+@@ -210,6 +210,8 @@
+ connect(cbposix, SIGNAL(stateChanged(int)), this, SLOT(changed()));
+ connect(cbposix, SIGNAL(stateChanged(int)), this, SLOT(cbposixChanged()));
+ addRow(frame, layout, row++, cbposix, i18n("Disable &POSIX account information"), whatstr);
++ } else {
++ cbposix = 0;
+ }
+ frontrow = row;
+ }
+@@ -706,7 +708,8 @@
+ bool posix, samba = false;
+
+ newuser->copy( user );
+- if ( cbposix->state() != QButton::NoChange ) {
++
++ if ( kug->getUsers().getCaps() & KUsers::Cap_Disable_POSIX && cbposix->state() != QButton::NoChange ) {
+ if ( cbposix->isChecked() )
+ newuser->setCaps( newuser->getCaps() & ~KUser::Cap_POSIX );
+ else
+@@ -873,7 +876,7 @@
+ bool propdlg::check()
+ {
+ bool one = ( mUsers.getFirst() == mUsers.getLast() );
+- bool posix = !( cbposix->isChecked() );
++ bool posix = !( kug->getUsers().getCaps() & KUsers::Cap_Disable_POSIX ) || !( cbposix->isChecked() );
+
+ if ( one && posix && leid->text().isEmpty() ) {
+ KMessageBox::sorry( 0, i18n("You need to specify an UID.") );
+@@ -928,7 +931,8 @@
+
+ uid_t newuid = leid->text().toULong();
+
+- if ( one && !cbposix->isChecked() && olduid != newuid )
++ if ( one && ( !( kug->getUsers().getCaps() & KUsers::Cap_Disable_POSIX ) || !cbposix->isChecked() )
++ && olduid != newuid )
+ {
+ if (kug->getUsers().lookup(newuid)) {
+ KMessageBox::sorry( 0,
diff --git a/kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild b/kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild
new file mode 100644
index 000000000000..31c6d95844d5
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild,v 1.1 2005/04/08 12:27:54 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE administration tools (user manager, etc.)"
+
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+IUSE=""
+
+DEPEND="~kde-base/kdebase-${PV}"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix /etc/passwd corruption in kuser (kde bug 100443). Applied for 3.4.1.
+ epatch "${FILESDIR}/${P}-kuser.patch"
+}
+
+src_compile() {
+ # we only want to compile the lilo config module on x86, but there we want to make sure it's
+ # always compiled to ensure consistent behaviour of the package across both lilo and grub systems,
+ # because configure when left to its own devices will build lilo-config or not basd on whether
+ # lilo is present in the path.
+ # so, we make configure build it by removing the configure.in.in file that checks for
+ # lilo's presense
+ if use x86; then
+ echo > ${S}/lilo-config/configure.in.in
+ make -f admin/Makefile.common
+ fi
+
+ export DO_NOT_COMPILE="${DO_NOT_COMPILE} ksysv"
+
+ kde_src_compile
+}
+
+# TODO: add nis support