summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-19 22:12:57 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-19 22:12:57 +0000
commit7bd0a982bcb2a795f0b6afa3fe0bd2629f29db6b (patch)
tree0c971cb6483eda01b92cf7aca1d002aeed6c10ae /kde-base/kdeadmin
parentBump to KDE 3.5.8. (diff)
downloadgentoo-2-7bd0a982bcb2a795f0b6afa3fe0bd2629f29db6b.tar.gz
gentoo-2-7bd0a982bcb2a795f0b6afa3fe0bd2629f29db6b.tar.bz2
gentoo-2-7bd0a982bcb2a795f0b6afa3fe0bd2629f29db6b.zip
Bump to KDE 3.5.8.
(Portage version: 2.1.3.15)
Diffstat (limited to 'kde-base/kdeadmin')
-rw-r--r--kde-base/kdeadmin/ChangeLog8
-rw-r--r--kde-base/kdeadmin/files/digest-kdeadmin-3.5.83
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.5.8.ebuild41
3 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/kdeadmin/ChangeLog b/kde-base/kdeadmin/ChangeLog
index ffd5602424b0..f8ac70f9b2f8 100644
--- a/kde-base/kdeadmin/ChangeLog
+++ b/kde-base/kdeadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeadmin
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.198 2007/09/24 03:52:12 redhatter Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.199 2007/10/19 22:12:57 philantrop Exp $
+
+*kdeadmin-3.5.8 (19 Oct 2007)
+
+ 19 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdeadmin-3.5.8.ebuild:
+ Bump to KDE 3.5.8.
24 Sep 2007; Stuart Longland <redhatter@gentoo.org> kdeadmin-3.5.7.ebuild:
Tested and working on MIPS. Keyworded ~mips.
diff --git a/kde-base/kdeadmin/files/digest-kdeadmin-3.5.8 b/kde-base/kdeadmin/files/digest-kdeadmin-3.5.8
new file mode 100644
index 000000000000..15f657087315
--- /dev/null
+++ b/kde-base/kdeadmin/files/digest-kdeadmin-3.5.8
@@ -0,0 +1,3 @@
+MD5 324a44d854a92177e71954f9264c98a8 kdeadmin-3.5.8.tar.bz2 2123522
+RMD160 b7ce226d5152ce40942e141891bddbaadf8571fc kdeadmin-3.5.8.tar.bz2 2123522
+SHA256 501c8dd591d112e4641b802dee175037616da7f492c865cccb13bb3aadcd6aea kdeadmin-3.5.8.tar.bz2 2123522
diff --git a/kde-base/kdeadmin/kdeadmin-3.5.8.ebuild b/kde-base/kdeadmin/kdeadmin-3.5.8.ebuild
new file mode 100644
index 000000000000..d25f9da12a37
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.5.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.5.8.ebuild,v 1.1 2007/10/19 22:12:57 philantrop Exp $
+
+inherit kde-dist
+
+DESCRIPTION="KDE administration tools (user manager, etc.)"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kdehiddenvisibility"
+
+DEPEND="~kde-base/kdebase-${PV}"
+RDEPEND="${DEPEND}
+ virtual/cron"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix desktop file
+ sed -i -e "s:\(Configuration-KDE-Network-mdk\):X-\1:" \
+ "${S}/knetworkconf/knetworkconf/kcm_knetworkconfmodule.desktop"
+}
+
+src_compile() {
+ # we only want to compile the lilo config module on x86, but there we want to make sure it's
+ # always compiled to ensure consistent behaviour of the package across both lilo and grub systems,
+ # because configure when left to its own devices will build lilo-config or not basd on whether
+ # lilo is present in the path.
+ # so, we make configure build it by removing the configure.in.in file that checks for
+ # lilo's presense
+ if use x86; then
+ echo > "${S}/lilo-config/configure.in.in"
+ make -f admin/Makefile.common
+ fi
+
+ local myconf="--with-shadow"
+
+ export DO_NOT_COMPILE="${DO_NOT_COMPILE} ksysv"
+
+ kde_src_compile
+}