summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-04 19:30:47 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-04 19:30:47 +0000
commitac2fc7b2db98c04967a88a433f7cfeb60c389323 (patch)
tree263867635d36ff95fd0e1dc9d62de089b7591798 /kde-base/kcheckpass
parentAdd ~mips keyword. (diff)
downloadgentoo-2-ac2fc7b2db98c04967a88a433f7cfeb60c389323.tar.gz
gentoo-2-ac2fc7b2db98c04967a88a433f7cfeb60c389323.tar.bz2
gentoo-2-ac2fc7b2db98c04967a88a433f7cfeb60c389323.zip
Version bump KDE Workspace 4.11.7
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.11.7.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 6c02182d3f5e..60c88bc634e8 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.308 2014/02/23 10:01:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.309 2014/03/04 19:30:43 johu Exp $
+
+*kcheckpass-4.11.7 (04 Mar 2014)
+
+ 04 Mar 2014; Johannes Huber <johu@gentoo.org> +kcheckpass-4.11.7.ebuild:
+ Version bump KDE Workspace 4.11.7
23 Feb 2014; Agostino Sarubbo <ago@gentoo.org> -kcheckpass-4.11.2.ebuild:
Remove old
diff --git a/kde-base/kcheckpass/kcheckpass-4.11.7.ebuild b/kde-base/kcheckpass/kcheckpass-4.11.7.ebuild
new file mode 100644
index 000000000000..0b6a1aaf58ec
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.11.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.11.7.ebuild,v 1.1 2014/03/04 19:30:43 johu Exp $
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}