summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
committerChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
commita7d39b161d3ea87618db515020379fc2be385858 (patch)
tree3fd47e295f81d71610e045a95b9b7a70e5373756 /kde-base/kcheckpass
parentAdd systemd support (#466084) (diff)
downloadgentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.gz
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.bz2
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.zip
Bump KDE to 4.1.1
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog8
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.11.1.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 39f283b0358e..729bb761be70 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.284 2013/08/14 20:23:51 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.285 2013/09/03 19:04:53 creffett Exp $
+
+*kcheckpass-4.11.1 (03 Sep 2013)
+
+ 03 Sep 2013; Chris Reffett <creffett@gentoo.org> +kcheckpass-4.11.1.ebuild,
+ files/kcheckpass-4.4.2-no-SUID-no-GUID.patch:
+ Bump KDE to 4.1.1
*kcheckpass-4.11.0 (14 Aug 2013)
diff --git a/kde-base/kcheckpass/kcheckpass-4.11.1.ebuild b/kde-base/kcheckpass/kcheckpass-4.11.1.ebuild
new file mode 100644
index 000000000000..5e2a36f85852
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.11.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.11.1.ebuild,v 1.1 2013/09/03 19:04:53 creffett Exp $
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}