summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-14 09:28:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-14 09:28:04 +0000
commit249304104d5eb38c013e6dba665d713cffc47fcc (patch)
treeddd82395ffded43638f34d20deb11e9df2855ff8 /kde-base/kcheckpass/kcheckpass-3.5.0.ebuild
parentUse patch from tarball in mirrors. (diff)
downloadgentoo-2-249304104d5eb38c013e6dba665d713cffc47fcc.tar.gz
gentoo-2-249304104d5eb38c013e6dba665d713cffc47fcc.tar.bz2
gentoo-2-249304104d5eb38c013e6dba665d713cffc47fcc.zip
Use patch from tarball in mirrors.
(Portage version: 2529-svn)
Diffstat (limited to 'kde-base/kcheckpass/kcheckpass-3.5.0.ebuild')
-rw-r--r--kde-base/kcheckpass/kcheckpass-3.5.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild b/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild
index 4c896197f261..4a6ca0e28fc2 100644
--- a/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild
+++ b/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild
@@ -1,18 +1,26 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild,v 1.6 2005/12/17 10:12:18 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-3.5.0.ebuild,v 1.7 2006/01/14 09:24:55 flameeyes Exp $
KMNAME=kdebase
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
inherit kde-meta eutils flag-o-matic
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-${PV}-patches-1.tar.bz2"
+
DESCRIPTION="A simple password checker, used by any software in need of user authentication."
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="pam"
DEPEND="pam? ( kde-base/kdebase-pam ) !pam? ( sys-apps/shadow )"
-PATCHES="${FILESDIR}/${P}-bindnow.patch"
+src_unpack() {
+ unpack "kdebase-${PV}-patches-1.tar.bz2"
+ kde-meta_src_unpack
+
+ epatch "${WORKDIR}/patches/${P}-bindnow.patch"
+}
src_compile() {
myconf="$(use_with pam)"