summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 18:16:46 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 18:16:46 +0000
commita6f664e0f6e489fec748c29ca3f05b359544b7ad (patch)
treed81c89b967cc0623d98d86903ab5d9e2eda1f916 /kde-base/kate
parentVersion bump KDE 4.3.2 (diff)
downloadgentoo-2-a6f664e0f6e489fec748c29ca3f05b359544b7ad.tar.gz
gentoo-2-a6f664e0f6e489fec748c29ca3f05b359544b7ad.tar.bz2
gentoo-2-a6f664e0f6e489fec748c29ca3f05b359544b7ad.zip
Version bump KDE 4.3.2
(Portage version: 2.2_rc44/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.3.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 1e8531cd086b..dabdd6cbbcd5 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.144 2009/09/01 14:50:50 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.145 2009/10/06 18:16:46 alexxy Exp $
+
+*kate-4.3.2 (06 Oct 2009)
+
+ 06 Oct 2009; Alexey Shvetsov <alexxy@gentoo.org> +kate-4.3.2.ebuild:
+ Version bump
*kate-4.3.1 (01 Sep 2009)
diff --git a/kde-base/kate/kate-4.3.2.ebuild b/kde-base/kate/kate-4.3.2.ebuild
new file mode 100644
index 000000000000..b5ab1cf49b05
--- /dev/null
+++ b/kde-base/kate/kate-4.3.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.3.2.ebuild,v 1.1 2009/10/06 18:16:46 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA="doc/kate-plugins"
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with plasma)"
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}