summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-03-30 19:31:27 +0000
committerDror Levin <spatz@gentoo.org>2010-03-30 19:31:27 +0000
commit00baff25ac670fb48d366850655440f11f7617f0 (patch)
treeaf09fd76b6870ced2005ac5dd5a0a05f1cd1b051 /kde-base/kate
parentVersion bump KDE 4.4.2 (diff)
downloadgentoo-2-00baff25ac670fb48d366850655440f11f7617f0.tar.gz
gentoo-2-00baff25ac670fb48d366850655440f11f7617f0.tar.bz2
gentoo-2-00baff25ac670fb48d366850655440f11f7617f0.zip
Version bump KDE 4.4.2
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.4.2.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 6587eaf671f3..a256c177bce3 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.169 2010/03/11 18:33:58 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.170 2010/03/30 19:31:27 spatz Exp $
+
+*kate-4.4.2 (30 Mar 2010)
+
+ 30 Mar 2010; Dror Levin <spatz@gentoo.org> +kate-4.4.2.ebuild:
+ Version bump
11 Mar 2010; Brent Baude <ranger@gentoo.org> kate-4.3.5.ebuild:
Marking kate-4.3.5 ppc stable for bug 300393
diff --git a/kde-base/kate/kate-4.4.2.ebuild b/kde-base/kate/kate-4.4.2.ebuild
new file mode 100644
index 000000000000..ea6d344e4be6
--- /dev/null
+++ b/kde-base/kate/kate-4.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.4.2.ebuild,v 1.1 2010/03/30 19:31:27 spatz Exp $
+
+EAPI="3"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}