summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-05 23:21:26 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-05 23:21:26 +0000
commit206a9b6154e40b9cba91d3931da4fab67f5858ad (patch)
tree517ff2c4a41a6db5f20a0c7ee1e8d250f06bdf3a /kde-base/kalzium
parentVersion bump KDE SC 4.5.1 (diff)
downloadgentoo-2-206a9b6154e40b9cba91d3931da4fab67f5858ad.tar.gz
gentoo-2-206a9b6154e40b9cba91d3931da4fab67f5858ad.tar.bz2
gentoo-2-206a9b6154e40b9cba91d3931da4fab67f5858ad.zip
Version bump KDE SC 4.5.1
(Portage version: 2.2_rc75/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog8
-rw-r--r--kde-base/kalzium/kalzium-4.5.1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 318adfd93e1a..a695cb8c3679 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.174 2010/08/09 17:34:12 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.175 2010/09/05 23:21:26 tampakrap Exp $
+
+*kalzium-4.5.1 (05 Sep 2010)
+
+ 05 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kalzium-4.5.1.ebuild:
+ Version bump
09 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org> kalzium-4.4.5.ebuild:
Drop alpha ia64 and sparc per the AT Lead permission.
diff --git a/kde-base/kalzium/kalzium-4.5.1.ebuild b/kde-base/kalzium/kalzium-4.5.1.ebuild
new file mode 100644
index 000000000000..16ec7fdda3b3
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.5.1.ebuild,v 1.1 2010/09/05 23:21:25 tampakrap Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK=1
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS=""
+IUSE="editor debug +plasma solver"
+
+RDEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${RDEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3:2 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-meta_src_configure
+}