summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 15:40:14 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 15:40:14 +0000
commit8218aad2c250405b32827dff9fbbd89c275786da (patch)
treecefcbb87abe2c090216c4e98d7fda05955d61313 /kde-base/kalgebra
parentVersion bump KDE 4.4.1 (diff)
downloadgentoo-2-8218aad2c250405b32827dff9fbbd89c275786da.tar.gz
gentoo-2-8218aad2c250405b32827dff9fbbd89c275786da.tar.bz2
gentoo-2-8218aad2c250405b32827dff9fbbd89c275786da.zip
Version bump KDE 4.4.1
(Portage version: 2.2_rc63/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kalgebra')
-rw-r--r--kde-base/kalgebra/ChangeLog8
-rw-r--r--kde-base/kalgebra/kalgebra-4.4.1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kalgebra/ChangeLog b/kde-base/kalgebra/ChangeLog
index 700a998f97f8..7cbdaa284a43 100644
--- a/kde-base/kalgebra/ChangeLog
+++ b/kde-base/kalgebra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalgebra
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.55 2010/02/20 10:01:44 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.56 2010/03/02 15:40:14 tampakrap Exp $
+
+*kalgebra-4.4.1 (02 Mar 2010)
+
+ 02 Mar 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kalgebra-4.4.1.ebuild:
+ Version bump
20 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> kalgebra-4.3.5.ebuild:
amd64/x86 stable wrt #300393
diff --git a/kde-base/kalgebra/kalgebra-4.4.1.ebuild b/kde-base/kalgebra/kalgebra-4.4.1.ebuild
new file mode 100644
index 000000000000..4098d12baab4
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.4.1.ebuild,v 1.1 2010/03/02 15:40:14 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdeedu"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook +plasma readline"
+
+DEPEND="
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libkdeedu/kdeeduui"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris-graph2d.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with readline)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test
+ sed -i -e '/mathmlpresentationtest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/analitza/tests/CMakeLists.txt || \
+ die "sed to disable mathmlpresentationtest failed."
+
+ kde4-meta_src_test
+}