summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-06 07:33:55 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-06 07:33:55 +0000
commit3771cd038d1a5171c2d63113dd48f27673e3ae98 (patch)
tree570fa773fa6cfe5ee5b812e68a6ac01da48af3fe /kde-base/kaddressbook
parentFix case where LINGUAS is unset or contains no supported language (diff)
downloadgentoo-2-3771cd038d1a5171c2d63113dd48f27673e3ae98.tar.gz
gentoo-2-3771cd038d1a5171c2d63113dd48f27673e3ae98.tar.bz2
gentoo-2-3771cd038d1a5171c2d63113dd48f27673e3ae98.zip
Start akonadi asynchronously on kde-4.6, bug 362199
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kaddressbook')
-rw-r--r--kde-base/kaddressbook/ChangeLog8
-rw-r--r--kde-base/kaddressbook/files/kaddressbook-4.4.10-asyncako.patch27
-rw-r--r--kde-base/kaddressbook/kaddressbook-4.4.10-r1.ebuild44
3 files changed, 78 insertions, 1 deletions
diff --git a/kde-base/kaddressbook/ChangeLog b/kde-base/kaddressbook/ChangeLog
index c360243b1f41..1a0fd7906977 100644
--- a/kde-base/kaddressbook/ChangeLog
+++ b/kde-base/kaddressbook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kaddressbook
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.179 2011/03/24 23:59:12 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.180 2011/04/06 07:33:55 dilfridge Exp $
+
+*kaddressbook-4.4.10-r1 (06 Apr 2011)
+
+ 06 Apr 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kaddressbook-4.4.10-r1.ebuild, +files/kaddressbook-4.4.10-asyncako.patch:
+ Start akonadi asynchronously on kde-4.6, bug 362199
24 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-kaddressbook-4.4.5.ebuild:
diff --git a/kde-base/kaddressbook/files/kaddressbook-4.4.10-asyncako.patch b/kde-base/kaddressbook/files/kaddressbook-4.4.10-asyncako.patch
new file mode 100644
index 000000000000..ac2acd394c59
--- /dev/null
+++ b/kde-base/kaddressbook/files/kaddressbook-4.4.10-asyncako.patch
@@ -0,0 +1,27 @@
+commit cfa404b7188e4c26bddbc9579728f6d25f8cd214
+Author: Stephen Kelly <steveire@gmail.com>
+Date: Tue Apr 5 11:09:43 2011 +0200
+
+ Start kdepim 4.4 asynchronously if built against 4.6.
+
+ The synchronous mechanism doesn't have enough time to start
+ before it reports failure.
+
+diff --git a/kaddressbook/main.cpp b/kaddressbook/main.cpp
+index 4c8ca42..200f8ec 100644
+--- a/kaddressbook/main.cpp
++++ b/kaddressbook/main.cpp
+@@ -49,11 +49,13 @@ int main( int argc, char **argv )
+ MainWindow *window = new MainWindow;
+ window->show();
+
++#if !KDE_IS_VERSION(4,6,0)
+ if ( !Akonadi::Control::start( window ) ) {
+ //TODO: add message box after string freeze
+ kWarning() << "Unable to start Akonadi server, exit application";
+ return 1;
+ }
++#endif
+
+ return app.exec();
+ }
diff --git a/kde-base/kaddressbook/kaddressbook-4.4.10-r1.ebuild b/kde-base/kaddressbook/kaddressbook-4.4.10-r1.ebuild
new file mode 100644
index 000000000000..8a9ea0244daf
--- /dev/null
+++ b/kde-base/kaddressbook/kaddressbook-4.4.10-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-4.4.10-r1.ebuild,v 1.1 2011/04/06 07:33:55 dilfridge Exp $
+
+EAPI="3"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="The KDE Address Book"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep libkdepim)
+ $(add_kdebase_dep libkleo)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+PATCHES=( "${FILESDIR}/${P}"-asyncako.patch )
+
+KMEXTRA="
+ plugins/kaddressbook/
+ plugins/ktexteditor/
+"
+KMEXTRACTONLY="
+ libkleo/
+"
+
+KMLOADLIBS="libkdepim"
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+}