summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 22:38:39 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 22:38:39 +0000
commitff31be0f5e935c8d64da1da3b94b89ce1ab8158e (patch)
tree57cd19a3b77b7073003ab0f5f3f7fb6d3dda044f /kde-base/dolphin
parentAdded KDE 4.0.4 version of cervisia. Thanks to Jorge Manuel B. S. Vicetto. (diff)
downloadgentoo-2-ff31be0f5e935c8d64da1da3b94b89ce1ab8158e.tar.gz
gentoo-2-ff31be0f5e935c8d64da1da3b94b89ce1ab8158e.tar.bz2
gentoo-2-ff31be0f5e935c8d64da1da3b94b89ce1ab8158e.zip
Added KDE 4.0.4 version of dolphin. Thanks to Jorge Manuel B. S. Vicetto.
(Portage version: 2.1.5)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.0.4.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 66aeddb03bec..df39392bfe04 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.7 2008/04/03 20:36:51 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.8 2008/05/15 22:38:38 ingmar Exp $
+
+*dolphin-4.0.4 (15 May 2008)
+
+ 15 May 2008; Ingmar Vanhassel <ingmar@gentoo.org> +dolphin-4.0.4.ebuild:
+ Added KDE 4.0.4 version of dolphin. Thanks to Jorge Manuel B. S. Vicetto.
*dolphin-4.0.3 (03 Apr 2008)
diff --git a/kde-base/dolphin/dolphin-4.0.4.ebuild b/kde-base/dolphin/dolphin-4.0.4.ebuild
new file mode 100644
index 000000000000..55cc2a2579d4
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.0.4.ebuild,v 1.1 2008/05/15 22:38:39 ingmar Exp $
+
+EAPI="1"
+
+KMNAME=kdebase
+KMMODULE=apps/${PN}
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook +semantic-desktop"
+
+DEPEND="
+ >=kde-base/libkonq-${PV}:${SLOT}
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT} )"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="apps/doc/${PN}"
+KMLOADLIBS="libkonq"
+
+PATCHES="${FILESDIR}/${PN}-4.0.2-make-semantic-desktop-optional.patch"
+
+pkg_setup() {
+ if use semantic-desktop; then
+ KDE4_BUILT_WITH_USE_CHECK="--missing false kde-base/kdelibs:${SLOT} semantic-desktop"
+ fi
+ kde4-meta_pkg_setup
+}
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+ kde4-meta_src_compile
+}