summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:16:25 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:16:25 +0000
commita7037f2fa1d7437f959ba4a3c3153d7347f82945 (patch)
tree66258db50141c00604afc7b96828c1fa05b7321a /kde-base/dolphin
parent[kde-base/kdeartwork-colorschemes] Version bump to KDE SC 4.4.0 (diff)
downloadgentoo-2-a7037f2fa1d7437f959ba4a3c3153d7347f82945.tar.gz
gentoo-2-a7037f2fa1d7437f959ba4a3c3153d7347f82945.tar.bz2
gentoo-2-a7037f2fa1d7437f959ba4a3c3153d7347f82945.zip
[kde-base/dolphin] Version bump to KDE SC 4.4.0
(Portage version: 2.2_rc62/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.4.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index b989335bbf21..6ec5372257ad 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.61 2010/01/25 14:23:16 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.62 2010/02/09 00:16:25 alexxy Exp $
+
+*dolphin-4.4.0 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
*dolphin-4.3.5 (25 Jan 2010)
diff --git a/kde-base/dolphin/dolphin-4.4.0.ebuild b/kde-base/dolphin/dolphin-4.4.0.ebuild
new file mode 100644
index 000000000000..c1052877f970
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.4.0.ebuild,v 1.1 2010/02/09 00:16:25 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook semantic-desktop subversion thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ subversion? ( dev-util/subversion )
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? ( $(add_kdebase_dep mplayerthumbs) )
+"
+
+KMLOADLIBS="libkonq"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if ! use subversion; then
+ sed -e '/install(.*fileviewsvnplugin.*)/s/^/#DONOTINSTALL /g' \
+ -i dolphin/src/CMakeLists.txt || die 'failed to disable subversion plugin'
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}