summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-05-31 14:29:03 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-05-31 14:29:03 +0000
commit9aa400f7ebd3c01d12ee3071f9f095e0f3c73e21 (patch)
tree83bec6024c4ef446356efe7d388b5e860c1e51cf /kde-base/dolphin
parentppc stable #270832 (diff)
downloadgentoo-2-9aa400f7ebd3c01d12ee3071f9f095e0f3c73e21.tar.gz
gentoo-2-9aa400f7ebd3c01d12ee3071f9f095e0f3c73e21.tar.bz2
gentoo-2-9aa400f7ebd3c01d12ee3071f9f095e0f3c73e21.zip
Revision bump, remove block of kde-misc/dolphin:3.5
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog9
-rw-r--r--kde-base/dolphin/dolphin-4.2.2-r1.ebuild34
-rw-r--r--kde-base/dolphin/dolphin-4.2.3-r1.ebuild34
3 files changed, 76 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index e6784daea8e7..66ec44665841 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.31 2009/05/06 22:49:24 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.32 2009/05/31 14:29:03 tampakrap Exp $
+
+*dolphin-4.2.3-r1 (31 May 2009)
+*dolphin-4.2.2-r1 (31 May 2009)
+
+ 31 May 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +dolphin-4.2.2-r1.ebuild, +dolphin-4.2.3-r1.ebuild:
+ Revision bump, remove blocker of kde-misc/dolphin:3.5
*dolphin-4.2.3 (06 May 2009)
diff --git a/kde-base/dolphin/dolphin-4.2.2-r1.ebuild b/kde-base/dolphin/dolphin-4.2.2-r1.ebuild
new file mode 100644
index 000000000000..54a786f74e98
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.2.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.2.2-r1.ebuild,v 1.1 2009/05/31 14:29:03 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc +semantic-desktop thumbnail"
+
+DEPEND="
+ >=kde-base/kdelibs-${PV}:${SLOT}[kdeprefix=,semantic-desktop=]
+ >=kde-base/libkonq-${PV}:${SLOT}[kdeprefix=]
+"
+RDEPEND="${DEPEND}
+ >=kde-base/kfind-${PV}:${SLOT}[kdeprefix=]
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT}[kdeprefix=] )
+"
+PDEPEND="
+ thumbnail? ( media-video/mplayerthumbs:1 )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+
+ kde4-meta_src_configure
+}
diff --git a/kde-base/dolphin/dolphin-4.2.3-r1.ebuild b/kde-base/dolphin/dolphin-4.2.3-r1.ebuild
new file mode 100644
index 000000000000..ba176ebce862
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.2.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.2.3-r1.ebuild,v 1.1 2009/05/31 14:29:03 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc +semantic-desktop thumbnail"
+
+DEPEND="
+ >=kde-base/kdelibs-${PV}:${SLOT}[kdeprefix=,semantic-desktop=]
+ >=kde-base/libkonq-${PV}:${SLOT}[kdeprefix=]
+"
+RDEPEND="${DEPEND}
+ >=kde-base/kfind-${PV}:${SLOT}[kdeprefix=]
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT}[kdeprefix=] )
+"
+PDEPEND="
+ thumbnail? ( media-video/mplayerthumbs:1 )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+
+ kde4-meta_src_configure
+}