summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-06-04 18:22:23 +0000
committerJohannes Huber <johu@gentoo.org>2013-06-04 18:22:23 +0000
commit20f55f8fb805f8021dd9ded690b2815eb78ffc4f (patch)
tree80067b7b6ce35f4bffa5921e939a528f7d1cae22 /kde-base/dolphin
parentVersion bump. (diff)
downloadgentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.tar.gz
gentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.tar.bz2
gentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.zip
Version bump KDE SC 4.10.4
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.10.4.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index e466550ab575..f29b08dba628 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.185 2013/06/04 13:05:38 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.186 2013/06/04 18:22:23 johu Exp $
+
+*dolphin-4.10.4 (04 Jun 2013)
+
+ 04 Jun 2013; Johannes Huber <johu@gentoo.org> +dolphin-4.10.4.ebuild:
+ Version bump KDE SC 4.10.4
04 Jun 2013; Agostino Sarubbo <ago@gentoo.org> dolphin-4.10.3.ebuild:
Stable for amd64, wrt to bug #471392
diff --git a/kde-base/dolphin/dolphin-4.10.4.ebuild b/kde-base/dolphin/dolphin-4.10.4.ebuild
new file mode 100644
index 000000000000..1f0a33b6def9
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.10.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.10.4.ebuild,v 1.1 2013/06/04 18:22:23 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep kdelibs 'semantic-desktop(+)?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? (
+ >=dev-libs/shared-desktop-ontologies-0.10.0
+ dev-libs/soprano
+ $(add_kdebase_dep nepomuk-core)
+ $(add_kdebase_dep nepomuk-widgets)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ $(add_kdebase_dep thumbnailers)
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+RESTRICT="test"
+# bug 393129
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop NepomukCore)
+ $(cmake-utils_use_with semantic-desktop NepomukWidgets)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version media-gfx/icoutils ; then
+ elog "For .exe file preview support, install media-gfx/icoutils."
+ fi
+}