summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-25 19:29:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-25 19:29:41 +0000
commitd4b7b55e5ac42a71c9dbeda8795a6289eb4f3200 (patch)
treec93ad9cd635aece6e18ee564f47acbc176ea5479 /kde-base/dcoppython
parentfixed deps, removing usage of gnome2-utils, cleanup (diff)
downloadgentoo-2-d4b7b55e5ac42a71c9dbeda8795a6289eb4f3200.tar.gz
gentoo-2-d4b7b55e5ac42a71c9dbeda8795a6289eb4f3200.tar.bz2
gentoo-2-d4b7b55e5ac42a71c9dbeda8795a6289eb4f3200.zip
Remove the Python 2.5 patch for 3.5.5 series, as it's broken for 64-bit arches; add patch to support Python 2.4 on 3.5.6.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'kde-base/dcoppython')
-rw-r--r--kde-base/dcoppython/ChangeLog10
-rw-r--r--kde-base/dcoppython/dcoppython-3.5.5-r1.ebuild27
-rw-r--r--kde-base/dcoppython/dcoppython-3.5.6.ebuild4
-rw-r--r--kde-base/dcoppython/files/dcoppython-3.5.6-python-2.4.patch24
-rw-r--r--kde-base/dcoppython/files/digest-dcoppython-3.5.5-r13
5 files changed, 65 insertions, 3 deletions
diff --git a/kde-base/dcoppython/ChangeLog b/kde-base/dcoppython/ChangeLog
index 40e77781bc65..22d87d660e69 100644
--- a/kde-base/dcoppython/ChangeLog
+++ b/kde-base/dcoppython/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/dcoppython
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dcoppython/ChangeLog,v 1.43 2007/01/16 19:22:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dcoppython/ChangeLog,v 1.44 2007/01/25 19:29:41 flameeyes Exp $
+
+*dcoppython-3.5.5-r1 (25 Jan 2007)
+
+ 25 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +files/dcoppython-3.5.6-python-2.4.patch, +dcoppython-3.5.5-r1.ebuild,
+ dcoppython-3.5.6.ebuild:
+ Remove the Python 2.5 patch for 3.5.5 series, as it's broken for 64-bit
+ arches; add patch to support Python 2.4 on 3.5.6.
*dcoppython-3.5.6 (16 Jan 2007)
diff --git a/kde-base/dcoppython/dcoppython-3.5.5-r1.ebuild b/kde-base/dcoppython/dcoppython-3.5.5-r1.ebuild
new file mode 100644
index 000000000000..2f4b45d6924d
--- /dev/null
+++ b/kde-base/dcoppython/dcoppython-3.5.5-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dcoppython/dcoppython-3.5.5-r1.ebuild,v 1.1 2007/01/25 19:29:41 flameeyes Exp $
+
+KMNAME=kdebindings
+KM_MAKEFILESREV=1
+MAXKDEVER=3.5.5
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE: Python bindings for DCOP"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/python"
+
+# Because this installs into /usr/lib/python2.3/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely
+SLOT="0"
+
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}
+
diff --git a/kde-base/dcoppython/dcoppython-3.5.6.ebuild b/kde-base/dcoppython/dcoppython-3.5.6.ebuild
index 77cef006387c..a6c130056a9a 100644
--- a/kde-base/dcoppython/dcoppython-3.5.6.ebuild
+++ b/kde-base/dcoppython/dcoppython-3.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dcoppython/dcoppython-3.5.6.ebuild,v 1.1 2007/01/16 19:22:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dcoppython/dcoppython-3.5.6.ebuild,v 1.2 2007/01/25 19:29:41 flameeyes Exp $
KMNAME=kdebindings
KM_MAKEFILESREV=1
@@ -18,7 +18,7 @@ DEPEND="virtual/python"
SLOT="0"
PATCHES="$FILESDIR/no-gtk-glib-check.diff
- ${FILESDIR}/dcoppython-3.5.5-python-2.5-compat.diff"
+ ${FILESDIR}/dcoppython-3.5.6-python-2.4.patch"
src_compile() {
kde_src_compile myconf
diff --git a/kde-base/dcoppython/files/dcoppython-3.5.6-python-2.4.patch b/kde-base/dcoppython/files/dcoppython-3.5.6-python-2.4.patch
new file mode 100644
index 000000000000..e6ba4409b881
--- /dev/null
+++ b/kde-base/dcoppython/files/dcoppython-3.5.6-python-2.4.patch
@@ -0,0 +1,24 @@
+Index: kdebindings/dcoppython/shell/marshaller.cpp
+===================================================================
+--- kdebindings/dcoppython/shell/marshaller.cpp (revision 626831)
++++ kdebindings/dcoppython/shell/marshaller.cpp (revision 626832)
+@@ -24,6 +24,10 @@
+
+ #include <kurl.h>
+
++#if PY_VERSION_HEX < 0x02050000
++typedef int Py_ssize_t;
++#endif
++
+ namespace PythonDCOP {
+
+ #include "marshal_funcs.h"
+@@ -124,7 +128,7 @@
+ if (!PyDict_Check(obj)) return false;
+
+
+- ssize_t c=0;
++ Py_ssize_t c=0;
+ PyObject *key, *val;
+ while (PyDict_Next(obj, &c, &key, &val)==1)
+ if (!key_type.isMarshallable(key) ||
diff --git a/kde-base/dcoppython/files/digest-dcoppython-3.5.5-r1 b/kde-base/dcoppython/files/digest-dcoppython-3.5.5-r1
new file mode 100644
index 000000000000..d6542e599565
--- /dev/null
+++ b/kde-base/dcoppython/files/digest-dcoppython-3.5.5-r1
@@ -0,0 +1,3 @@
+MD5 e0da219943407a786c2ceea1605fadd1 kdebindings-3.5.5.tar.bz2 5419613
+RMD160 8515555111e2745f63b403d3255ff5521bf77875 kdebindings-3.5.5.tar.bz2 5419613
+SHA256 54751d3fe6635abf7bb8ef08ff240354e56dfaaa02cd16b1dd2a837706c4b274 kdebindings-3.5.5.tar.bz2 5419613