summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-07-28 12:52:34 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-07-28 12:52:34 +0000
commit94cbde5f4880b015d935c96759c60a586258a6a9 (patch)
treefcf6fb09767ca5a5e8a1953b6a78bd1353738afc /kde-base/arts
parentx86 stable and old version removal (diff)
downloadgentoo-2-94cbde5f4880b015d935c96759c60a586258a6a9.tar.gz
gentoo-2-94cbde5f4880b015d935c96759c60a586258a6a9.tar.bz2
gentoo-2-94cbde5f4880b015d935c96759c60a586258a6a9.zip
Update to KDE 3.4.2.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'kde-base/arts')
-rw-r--r--kde-base/arts/ChangeLog7
-rw-r--r--kde-base/arts/arts-3.4.2.ebuild92
-rw-r--r--kde-base/arts/files/digest-arts-3.4.21
3 files changed, 99 insertions, 1 deletions
diff --git a/kde-base/arts/ChangeLog b/kde-base/arts/ChangeLog
index 18f818610493..4e0d862e5a63 100644
--- a/kde-base/arts/ChangeLog
+++ b/kde-base/arts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/arts
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.173 2005/07/25 18:22:46 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.174 2005/07/28 12:51:26 greg_g Exp $
+
+*arts-3.4.2 (28 Jul 2005)
+
+ 28 Jul 2005; Gregorio Guidi <greg_g@gentoo.org> +arts-3.4.2.ebuild:
+ New version. Add support for nas (#97030).
25 Jul 2005; Guy Martin <gmsoft@gentoo.org> arts-3.4.1-r2.ebuild:
Stable on hppa.
diff --git a/kde-base/arts/arts-3.4.2.ebuild b/kde-base/arts/arts-3.4.2.ebuild
new file mode 100644
index 000000000000..ce224c2a7451
--- /dev/null
+++ b/kde-base/arts/arts-3.4.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-3.4.2.ebuild,v 1.1 2005/07/28 12:51:26 greg_g Exp $
+
+inherit kde flag-o-matic eutils
+set-kdedir 3.4
+
+MY_PV=${PV/#3/1}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DESCRIPTION="aRts, the KDE sound (and all-around multimedia) server/output manager"
+HOMEPAGE="http://multimedia.kde.org/"
+SRC_URI="mirror://kde/stable/${PV}/src/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa esd artswrappersuid jack mp3 nas hardened vorbis"
+
+RDEPEND="$(qt_min_version 3.3)
+ >=dev-libs/glib-2
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libvorbis media-libs/libogg )
+ esd? ( media-sound/esound )
+ jack? ( media-sound/jack-audio-connection-kit )
+ mp3? ( media-libs/libmad )
+ nas? ( media-libs/nas )
+ media-libs/audiofile"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ kde_src_unpack
+ epatch "${FILESDIR}/arts-1.3.2-alsa-bigendian.patch"
+
+ if (is-flag -fstack-protector || is-flag -fstack-protector-all || use hardened); then
+ epatch ${FILESDIR}/arts-1.4-mcopidl.patch
+ fi
+
+ # Configure patch. Applied for 3.5.
+ epatch "${FILESDIR}/arts-3.4.1-configure.patch"
+
+ # for the configure patch
+ make -f admin/Makefile.common || die
+}
+
+src_compile() {
+ myconf="$(use_enable alsa) $(use_enable vorbis)
+ $(use_enable mp3 libmad) $(use_with jack)
+ $(use_with esd) $(use_with nas)
+ --with-audiofile --without-mas"
+
+ #fix bug 13453
+ filter-flags -foptimize-sibling-calls
+
+ #fix bug 41980
+ use sparc && filter-flags -fomit-frame-pointer
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ # moved here from kdelibs so that when arts is installed
+ # without kdelibs it's still in the path.
+ # List all the multilib libdirs
+ local libdirs
+ for libdir in $(get_all_libdirs); do
+ libdirs="${libdirs}:${PREFIX}/${libdir}"
+ done
+
+ dodir /etc/env.d
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${libdirs:1}
+CONFIG_PROTECT=\"${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown\"" > ${D}/etc/env.d/46kdepaths-3.4 # number goes down with version upgrade
+
+ # used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s ${D}/${PREFIX}/bin/artswrapper
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ einfo "Run chmod u+s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
+ einfo "and so avoid possible skips in sound. However, on untrusted systems this"
+ einfo "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ einfo "priority, and so is off by default. See bug #7883."
+ einfo "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+ fi
+}
diff --git a/kde-base/arts/files/digest-arts-3.4.2 b/kde-base/arts/files/digest-arts-3.4.2
new file mode 100644
index 000000000000..29706071c7fa
--- /dev/null
+++ b/kde-base/arts/files/digest-arts-3.4.2
@@ -0,0 +1 @@
+MD5 bfa5b0efa7454c15976c4e5c618d2db4 arts-1.4.2.tar.bz2 975790