summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-10-25 19:58:39 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-10-25 19:58:39 +0000
commitd184f1ab9f020bfde5c438ef4619ca58de2159f7 (patch)
tree7d64a3c945eda98cf0dbc517b9c12bbccf4f6c1e /kde-base/ark
parentVersion bump (diff)
downloadgentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.tar.gz
gentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.tar.bz2
gentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.zip
Version bump KDE SC 4.14.2
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/ark')
-rw-r--r--kde-base/ark/ChangeLog7
-rw-r--r--kde-base/ark/ark-4.14.2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/ark/ChangeLog b/kde-base/ark/ChangeLog
index a704dd79c3b7..02be1334e57c 100644
--- a/kde-base/ark/ChangeLog
+++ b/kde-base/ark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ark
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.337 2014/09/16 18:17:25 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.338 2014/10/25 19:58:31 kensington Exp $
+
+*ark-4.14.2 (25 Oct 2014)
+
+ 25 Oct 2014; Michael Palimaka <kensington@gentoo.org> +ark-4.14.2.ebuild:
+ Version bump KDE SC 4.14.2
*ark-4.14.1 (16 Sep 2014)
diff --git a/kde-base/ark/ark-4.14.2.ebuild b/kde-base/ark/ark-4.14.2.ebuild
new file mode 100644
index 000000000000..cf4e04550847
--- /dev/null
+++ b/kde-base/ark/ark-4.14.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.14.2.ebuild,v 1.1 2014/10/25 19:58:31 kensington Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="http://www.kde.org/applications/utilities/ark
+http://utils.kde.org/projects/ark"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1:=[bzip2?,lzma?,zlib] )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# dbus problem
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version app-arch/rar ; then
+ elog "For creating rar archives, install app-arch/rar"
+ fi
+}