summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
commit15e1e7fdd1e191927f169caf35f9223d23a57246 (patch)
treea24b9205d75050edee2d793b88c839b440af63fc /kde-base/ark
parentAdd net-misc/leechcraft-launchy, thanks to 0xd34df00d (diff)
downloadgentoo-2-15e1e7fdd1e191927f169caf35f9223d23a57246.tar.gz
gentoo-2-15e1e7fdd1e191927f169caf35f9223d23a57246.tar.bz2
gentoo-2-15e1e7fdd1e191927f169caf35f9223d23a57246.zip
Version bump KDE SC 4.9.1
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ark')
-rw-r--r--kde-base/ark/ChangeLog7
-rw-r--r--kde-base/ark/ark-4.9.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/ark/ChangeLog b/kde-base/ark/ChangeLog
index a1cd9797aebc..f674cd13b937 100644
--- a/kde-base/ark/ChangeLog
+++ b/kde-base/ark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.239 2012/09/03 13:29:56 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.240 2012/09/04 18:45:12 johu Exp $
+
+*ark-4.9.1 (04 Sep 2012)
+
+ 04 Sep 2012; Johannes Huber <johu@gentoo.org> +ark-4.9.1.ebuild:
+ Version bump KDE SC 4.9.1
03 Sep 2012; Johannes Huber <johu@gentoo.org> -ark-4.7.4.ebuild:
Remove KDE SC 4.7.4
diff --git a/kde-base/ark/ark-4.9.1.ebuild b/kde-base/ark/ark-4.9.1.ebuild
new file mode 100644
index 000000000000..abfd9fda610b
--- /dev/null
+++ b/kde-base/ark/ark-4.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.9.1.ebuild,v 1.1 2012/09/04 18:45:12 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# dbus problem
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+ elog "For creating rar archives, install app-arch/rar"
+}