summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-12-01 09:56:25 +0000
committerAlex Alexander <wired@gentoo.org>2009-12-01 09:56:25 +0000
commitdb1160bfa7093c03f23eeb84e07f86f3a1ce537c (patch)
tree0bef686ec2c394fff5996cb442c280abb736909e /kde-base/ark/ark-4.3.4.ebuild
parentadd ~amd64, bug #276760 (diff)
downloadgentoo-2-db1160bfa7093c03f23eeb84e07f86f3a1ce537c.tar.gz
gentoo-2-db1160bfa7093c03f23eeb84e07f86f3a1ce537c.tar.bz2
gentoo-2-db1160bfa7093c03f23eeb84e07f86f3a1ce537c.zip
Version bump KDE 4.3.4
(Portage version: 2.2_rc54/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ark/ark-4.3.4.ebuild')
-rw-r--r--kde-base/ark/ark-4.3.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-base/ark/ark-4.3.4.ebuild b/kde-base/ark/ark-4.3.4.ebuild
new file mode 100644
index 000000000000..f63eef47fcf6
--- /dev/null
+++ b/kde-base/ark/ark-4.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.3.4.ebuild,v 1.1 2009/12/01 09:56:25 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+archive +bzip2 debug +handbook lzma zip"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+ lzma? ( app-arch/xz-utils )
+ zip? ( >=dev-libs/libzip-0.8 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ $(cmake-utils_use_with zip LibZip)
+ "
+ kde4-meta_src_configure
+}