summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
committerJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
commitc9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f (patch)
tree94015d5f29e37019f20bdced917f52e9b11645da /kde-base/analitza/analitza-4.13.3.ebuild
parentAdd kde-workspace 4.11.11 SRC_URI, remove obsolete. (diff)
downloadgentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.gz
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.bz2
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.zip
Version bump KDE SC 4.13.3
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/analitza/analitza-4.13.3.ebuild')
-rw-r--r--kde-base/analitza/analitza-4.13.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-base/analitza/analitza-4.13.3.ebuild b/kde-base/analitza/analitza-4.13.3.ebuild
new file mode 100644
index 000000000000..c79d6dda2b79
--- /dev/null
+++ b/kde-base/analitza/analitza-4.13.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/analitza/analitza-4.13.3.ebuild,v 1.1 2014/07/16 17:40:24 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="never"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE library for mathematical features"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug readline"
+
+DEPEND="
+ opengl? ( virtual/glu )
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with readline)
+ )
+
+ kde4-base_src_configure
+}