summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-03-04 20:18:04 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-03-04 20:18:04 +0000
commitfda79ae780ba799df96e1ccae6a043fb35754a01 (patch)
tree3885a3d6970d53e55b531065291b083c02502d5c /kde-base/akonadi
parentppc stable, bug #260266 (diff)
downloadgentoo-2-fda79ae780ba799df96e1ccae6a043fb35754a01.tar.gz
gentoo-2-fda79ae780ba799df96e1ccae6a043fb35754a01.tar.bz2
gentoo-2-fda79ae780ba799df96e1ccae6a043fb35754a01.zip
Bump KDE 4.2.1
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/akonadi')
-rw-r--r--kde-base/akonadi/ChangeLog7
-rw-r--r--kde-base/akonadi/akonadi-4.2.1.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/kde-base/akonadi/ChangeLog b/kde-base/akonadi/ChangeLog
index 9102c125aea2..87389d8c53d8 100644
--- a/kde-base/akonadi/ChangeLog
+++ b/kde-base/akonadi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/akonadi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.11 2009/02/28 10:29:40 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.12 2009/03/04 20:18:04 alexxy Exp $
+
+*akonadi-4.2.1 (04 Mar 2009)
+
+ 04 Mar 2009; Alexey Shvetsov <alexxy@gentoo.org> +akonadi-4.2.1.ebuild:
+ Bump KDE 4.2.1
28 Feb 2009; Markus Meier <maekke@gentoo.org> metadata.xml:
semantic-desktop is a global USE-flag
diff --git a/kde-base/akonadi/akonadi-4.2.1.ebuild b/kde-base/akonadi/akonadi-4.2.1.ebuild
new file mode 100644
index 000000000000..f96d0e6e13ae
--- /dev/null
+++ b/kde-base/akonadi/akonadi-4.2.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/akonadi-4.2.1.ebuild,v 1.1 2009/03/04 20:18:04 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="An extensible cross-desktop storage service for PIM data and meta data"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+# add when libmapi becomes available with an ebuild
+#exchange
+IUSE="debug +semantic-desktop"
+
+# add when libmapi becomes available with an ebuild
+#exchange? ( net-libs/libmapi )
+# not sure about libxml2... - reavertm
+DEPEND="
+ dev-libs/boost
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=kde-base/kdemaildir-${PV}:${SLOT}
+ >=kde-base/libkdepim-${PV}:${SLOT}
+ x11-misc/shared-mime-info
+ >=kde-base/kdelibs-${PV}:${SLOT}[semantic-desktop?]
+"
+
+RDEPEND="${DEPEND}
+ >=app-office/akonadi-server-1.1[mysql]
+"
+
+KMEXTRACTONLY="
+ libkdepim/
+ maildir/
+"
+
+src_prepare() {
+ if ! use semantic-desktop; then
+ sed -i -e "s/add_subdirectory( nepomuktag )//"\
+ akonadi/resources/CMakeLists.txt\
+ || die "Failed to disable nepomuktag"
+ fi
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ # Set the dbus dirs, otherwise it searches in KDEDIR
+ mycmakeargs="${mycmakeargs}
+ -DAKONADI_DBUS_INTERFACES_INSTALL_DIR=/usr/share/dbus-1/interfaces
+ -DAKONADI_DBUS_SERVICES_INSTALL_DIR=/usr/share/dbus-1/services"
+ # replace with $(cmake-utils_use_with exchange OpenChange) when libmapi becomes available with an ebuild
+ mycmakeargs="${mycmakeargs}
+ -DWITH_LibXslt=ON
+ -DWITH_OpenChange=OFF
+ -DWITH_GNOKII=OFF
+ -DWITH_GLIB2=OFF
+ -DWITH_OpenSync=OFF
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test
+ sed -i -e '/mailserializerplugintest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/akonadi/plugins/tests/CMakeLists.txt || \
+ die "sed to disable mailserializerplugintest failed."
+
+ kde4-meta_src_test
+}