summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-10-06 09:16:48 +0000
committerDan Armak <danarmak@gentoo.org>2001-10-06 09:16:48 +0000
commitcdfb37bf27062f81756e66afacfe8aeec61b5719 (patch)
treea9aea19bc59087035666182eb47dfde5193026ba /incoming
parenttypo fix (diff)
downloadgentoo-2-cdfb37bf27062f81756e66afacfe8aeec61b5719.tar.gz
gentoo-2-cdfb37bf27062f81756e66afacfe8aeec61b5719.tar.bz2
gentoo-2-cdfb37bf27062f81756e66afacfe8aeec61b5719.zip
new incoming
Diffstat (limited to 'incoming')
-rw-r--r--incoming/pygame-1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/incoming/pygame-1.2.ebuild b/incoming/pygame-1.2.ebuild
new file mode 100644
index 000000000000..5f9acabc5250
--- /dev/null
+++ b/incoming/pygame-1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author David Creswick <davidc@sat.net>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
+
+SRC_URI="http://www.pygame.org/ftp/${P}.tar.gz"
+
+HOMEPAGE="http://www.pygame.org/"
+
+#build-time dependencies
+DEPEND=">=media-libs/libsdl-1.2.0
+ >=dev-lang/python-2.0
+ >=media-libs/sdl-ttf-2.0.3
+ >=media-libs/sdl-image-1.2.0
+ >=media-libs/sdl-mixer-1.2.0
+ >=dev-python/Numeric-19.0.0
+ >=media-libs/smpeg-0.4.4"
+
+src_compile() {
+ try python setup.py build
+}
+
+src_install () {
+ echo ${D}
+ try python setup.py install --prefix=${D}/usr
+}
+