summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-09-11 20:20:42 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-09-11 20:20:42 +0000
commitc606f573c237f339531deb185c92275c32aa2af2 (patch)
tree936b71a24bbea5f389cde7d8ce3d9f34f613f623 /gnustep-libs/objcunit/objcunit-1.2-r1.ebuild
parentstable x86, bug 190183 (diff)
downloadgentoo-2-c606f573c237f339531deb185c92275c32aa2af2.tar.gz
gentoo-2-c606f573c237f339531deb185c92275c32aa2af2.tar.bz2
gentoo-2-c606f573c237f339531deb185c92275c32aa2af2.zip
Fixed installation for gnustep-make-2
(Portage version: 2.1.3.9)
Diffstat (limited to 'gnustep-libs/objcunit/objcunit-1.2-r1.ebuild')
-rw-r--r--gnustep-libs/objcunit/objcunit-1.2-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnustep-libs/objcunit/objcunit-1.2-r1.ebuild b/gnustep-libs/objcunit/objcunit-1.2-r1.ebuild
new file mode 100644
index 000000000000..975d0910d9df
--- /dev/null
+++ b/gnustep-libs/objcunit/objcunit-1.2-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/objcunit/objcunit-1.2-r1.ebuild,v 1.1 2007/09/11 20:20:41 voyageur Exp $
+
+S=${WORKDIR}/ObjcUnit-1.2/ObjcUnit
+
+inherit gnustep-2
+
+DESCRIPTION="ObjcUnit: a unit testing framework for Obj-C on MacOSX and GNUstep"
+HOMEPAGE="http://oops.se/objcunit/"
+#SRC_URI="ftp://ftp.oops.se/pub/software/ObjcUnit/ObjcUnit-${PV}.tar.gz"
+# note: we cannot take original upstream sources, as they need GNUstep
+# patches, which are included in below URL
+SRC_URI="http://xanthippe.dyndns.org/Zipper/ObjcUnit-${PV}-GNUstep.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="IBM"
+SLOT="0"
+
+src_install() {
+ gnustep-base_src_install
+ dosym ${GNUSTEP_SYSTEM_LIBRARY}/Frameworks/ObjcUnit.framework/Headers ${GNUSTEP_SYSTEM_LIBRARY}/Headers/ObjcUnit
+}