summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-01-28 18:10:51 +0000
committerSimon Stelling <blubb@gentoo.org>2006-01-28 18:10:51 +0000
commitfe961a2702d7faf148a38bf00403d889aa019041 (patch)
treec8df81d71237fe59e169caf4fdd07c6029a71833 /gnustep-base
parentStable on ppc, bug #120743 (diff)
downloadgentoo-2-fe961a2702d7faf148a38bf00403d889aa019041.tar.gz
gentoo-2-fe961a2702d7faf148a38bf00403d889aa019041.tar.bz2
gentoo-2-fe961a2702d7faf148a38bf00403d889aa019041.zip
no need to bzip a smallish patch
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-gui/ChangeLog9
-rw-r--r--gnustep-base/gnustep-gui/files/gui-use-giflib.patch384
-rw-r--r--gnustep-base/gnustep-gui/files/gui-use-giflib.patch.bz2bin3037 -> 0 bytes
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.9.4-r2.ebuild6
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.9.5_pre20050312-r1.ebuild6
5 files changed, 397 insertions, 8 deletions
diff --git a/gnustep-base/gnustep-gui/ChangeLog b/gnustep-base/gnustep-gui/ChangeLog
index a42398a38a31..638db64a757a 100644
--- a/gnustep-base/gnustep-gui/ChangeLog
+++ b/gnustep-base/gnustep-gui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-base/gnustep-gui
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.36 2005/12/23 23:55:59 blubb Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.37 2006/01/28 18:08:09 blubb Exp $
+
+ 28 Jan 2006; Simon Stelling <blubb@gentoo.org>
+ +files/gui-use-giflib.patch, -files/gui-use-giflib.patch.bz2,
+ gnustep-gui-0.9.4-r2.ebuild, gnustep-gui-0.9.5_pre20050312-r1.ebuild:
+ no need to bzip a smallish patch
23 Dec 2005; Simon Stelling <blubb@gentoo.org> gnustep-gui-0.9.5.ebuild:
stable on amd64
diff --git a/gnustep-base/gnustep-gui/files/gui-use-giflib.patch b/gnustep-base/gnustep-gui/files/gui-use-giflib.patch
new file mode 100644
index 000000000000..683011814a3c
--- /dev/null
+++ b/gnustep-base/gnustep-gui/files/gui-use-giflib.patch
@@ -0,0 +1,384 @@
+diff -ur gnustep-cvs/core/gui/Headers/Additions/GNUstepGUI/config.h.in gnustep-cvs-test/core/gui/Headers/Additions/GNUstepGUI/config.h.in
+--- gnustep-cvs/core/gui/Headers/Additions/GNUstepGUI/config.h.in 2004-06-01 01:50:56.000000000 -0400
++++ gnustep-cvs-test/core/gui/Headers/Additions/GNUstepGUI/config.h.in 2005-03-18 01:19:45.694954256 -0500
+@@ -36,6 +36,9 @@
+ /* Define to 1 if you have the `ungif' library (-lungif). */
+ #undef HAVE_LIBUNGIF
+
++/* Define to 1 if you have the `giflib' library (-lgif). */
++#undef HAVE_LIBGIF
++
+ /* Define to 1 if you have the `z' library (-lz). */
+ #undef HAVE_LIBZ
+
+diff -ur gnustep-cvs/core/gui/Source/NSBitmapImageRep+GIF.m gnustep-cvs-test/core/gui/Source/NSBitmapImageRep+GIF.m
+--- gnustep-cvs/core/gui/Source/NSBitmapImageRep+GIF.m 2004-01-08 17:31:40.000000000 -0500
++++ gnustep-cvs-test/core/gui/Source/NSBitmapImageRep+GIF.m 2005-03-18 01:23:47.593180136 -0500
+@@ -28,7 +28,7 @@
+ #include "config.h"
+ #include "NSBitmapImageRep+GIF.h"
+
+-#if HAVE_LIBUNGIF
++#if HAVE_LIBUNGIF || HAVE_GIFLIB
+
+ /*
+ gif_lib.h (4.1.0b1, possibly other versions) uses Object as the name of an
+@@ -336,7 +336,7 @@
+
+ @end
+
+-#else /* !HAVE_LIBUNGIF */
++#else /* !HAVE_LIBUNGIF || !HAVE_GIFLIB */
+
+ @implementation NSBitmapImageRep (GIFReading)
+ + (BOOL) _bitmapIsGIF: (NSData *)imageData
+@@ -351,5 +351,5 @@
+ }
+ @end
+
+-#endif /* !HAVE_LIBUNGIF */
++#endif /* !HAVE_LIBUNGIF || !HAVE_GIFLIB */
+
+diff -ur gnustep-cvs/core/gui/Source/NSBitmapImageRep.m gnustep-cvs-test/core/gui/Source/NSBitmapImageRep.m
+--- gnustep-cvs/core/gui/Source/NSBitmapImageRep.m 2005-01-18 10:35:51.000000000 -0500
++++ gnustep-cvs-test/core/gui/Source/NSBitmapImageRep.m 2005-03-18 01:24:00.998142272 -0500
+@@ -133,7 +133,7 @@
+ types = [[NSArray alloc] initWithObjects:
+ @"tiff", @"tif",
+ @"pnm", @"ppm",
+-#if HAVE_LIBUNGIF
++#if HAVE_LIBUNGIF || HAVE_GIFLIB
+ @"gif",
+ #endif
+ #if HAVE_LIBJPEG
+diff -ur gnustep-cvs/core/gui/configure gnustep-cvs-test/core/gui/configure
+--- gnustep-cvs/core/gui/configure 2005-03-09 23:16:40.000000000 -0500
++++ gnustep-cvs-test/core/gui/configure 2005-03-18 01:32:44.662533184 -0500
+@@ -852,6 +852,7 @@
+ --disable-jpeg Disable JPEG support
+ --disable-png Disable PNG support
+ --disable-ungif Disable libungif-based GIF support
++ --enable-giflib Enable giflib-based GIF support
+ --disable-gsnd Disable gsnd server
+ --disable-cups Disable cups printing support
+
+@@ -865,6 +866,8 @@
+ --with-tiff-include=DIR TIFF include files are in DIR
+ --with-ungif-library=DIR UNGIF library file are in DIR
+ --with-ungif-include=DIR UNGIF include files are in DIR
++ --with-giflib-library=DIR GIFLIB library file are in DIR
++ --with-giflib-include=DIR GIFLIB include files are in DIR
+ --with-audiofile-library=DIR AUDIOFILE library file are in DIR
+ --with-audiofile-include=DIR AUDIOFILE include files are in DIR
+
+@@ -4990,6 +4993,7 @@
+ fi
+
+
++### --- libungif --- ###
+ # Check whether --enable-ungif or --disable-ungif was given.
+ if test "${enable_ungif+set}" = set; then
+ enableval="$enable_ungif"
+@@ -5209,6 +5213,226 @@
+ fi
+ fi
+
++### --- giflib --- ###
++# Check whether --enable-giflib or --disable-giflib was given.
++if test "${enable_giflib+set}" = set; then
++ enableval="$enable_giflib"
++
++else
++ enable_giflib=no
++fi;
++
++
++# Check whether --with-giflib_library or --without-giflib_library was given.
++if test "${with_giflib_library+set}" = set; then
++ withval="$with_giflib_library"
++
++else
++ with_ungif_library=
++fi;
++
++# Check whether --with-giflib_include or --without-giflib_include was given.
++if test "${with_giflib_include+set}" = set; then
++ withval="$with_giflib_include"
++
++else
++ with_giflib_include=
++fi;
++
++if test "${enable_giflib}" = yes; then
++ orig_CPPFLAGS="${CPPFLAGS}"
++ orig_LDFLAGS="${LDFLAGS}"
++ orig_LIBS="${LIBS}"
++
++ if test -n "${with_giflib_library}"; then
++ with_giflib_library="-L$with_giflib_library"
++ fi
++ if test -n "${with_giflib_include}"; then
++ with_giflib_include="-I$with_giflib_include"
++ fi
++ CPPFLAGS="${with_giflib_include} ${CPPFLAGS}"
++ LDFLAGS="${with_giflib_library} ${LDFLAGS}"
++
++
++echo "$as_me:$LINENO: checking for DGifOpen in -lgif" >&5
++echo $ECHO_N "checking for DGifOpen in -lgif... $ECHO_C" >&6
++if test "${ac_cv_lib_gif_DGifOpen+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lgif $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char DGifOpen ();
++int
++main ()
++{
++DGifOpen ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_gif_DGifOpen=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_gif_DGifOpen=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_gif_DGifOpen" >&5
++echo "${ECHO_T}$ac_cv_lib_gif_DGifOpen" >&6
++if test $ac_cv_lib_gif_DGifOpen = yes; then
++ cat >>confdefs.h <<_ACEOF
++#define HAVE_LIBGIF 1
++_ACEOF
++
++ LIBS="-lgif $LIBS"
++
++fi
++
++
++ if test "${with_x}" != no && test "${ac_cv_lib_giflib_DGifOpen}" = no; then
++ { echo "$as_me:$LINENO: Checking if giflib is linked against -lX11" >&5
++echo "$as_me: Checking if giflib is linked against -lX11" >&6;}
++ # This implies either that giflib is not installed at all, or that it
++ # explicitly refers to the symbols defined in X11. Now see if the latter
++ # is the case.
++ CPPFLAGS="${CPPFLAGS} -I${ac_x_includes}"
++ LDFLAGS="${LDFLAGS} -L${ac_x_libraries}"
++ LIBS="${LIBS} -lX11"
++
++
++echo "$as_me:$LINENO: checking for DGifCloseFile in -lgif" >&5
++echo $ECHO_N "checking for DGifCloseFile in -lgif... $ECHO_C" >&6
++if test "${ac_cv_lib_gif_DGifCloseFile+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lgif $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char DGifCloseFile ();
++int
++main ()
++{
++DGifCloseFile ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_gif_DGifCloseFile=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_gif_DGifCloseFile=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_gif_DGifCloseFile" >&5
++echo "${ECHO_T}$ac_cv_lib_gif_DGifCloseFile" >&6
++if test $ac_cv_lib_gif_DGifCloseFile = yes; then
++ cat >>confdefs.h <<_ACEOF
++#define HAVE_LIBGIF 1
++_ACEOF
++
++ LIBS="-lgif $LIBS"
++
++fi
++
++ if test "${ac_cv_lib_giflib_DGifCloseFile}" = no; then
++ # This indicates giflib is not installed at all. The flags reverts to
++ # the orignal value.
++ CPPFLAGS="${orig_CPPFLAGS}"
++ LDFLAGS="${orig_LDFLAGS}"
++ LIBS="${orig_LIBS}"
++ else
++ # This indicates giflib actually refers to the X11's symbols. We modify
++ # the flags so that -gui gets linked against the X11 library to support
++ # giflib.
++ { echo "$as_me:$LINENO: -gui will be linked against -lX11 to support giflib images" >&5
++echo "$as_me: -gui will be linked against -lX11 to support giflib images" >&6;}
++ GRAPHIC_CFLAGS="-I${ac_x_includes} ${with_giflib_include} $GRAPHIC_CFLAGS"
++ GRAPHIC_LFLAGS="-L${ac_x_libraries} ${with_giflib_library} $GRAPHIC_LFLAGS"
++ fi
++ else
++ GRAPHIC_CFLAGS="${with_giflib_include} $GRAPHIC_CFLAGS"
++ GRAPHIC_LFLAGS="${with_giflib_library} $GRAPHIC_LFLAGS"
++ fi
++fi
++
+ #--------------------------------------------------------------------
+ # Check for the spelling lib, for the built-in spell checker...
+ #--------------------------------------------------------------------
+diff -ur gnustep-cvs/core/gui/configure.ac gnustep-cvs-test/core/gui/configure.ac
+--- gnustep-cvs/core/gui/configure.ac 2005-03-09 23:16:40.000000000 -0500
++++ gnustep-cvs-test/core/gui/configure.ac 2005-03-18 01:32:26.442303080 -0500
+@@ -193,6 +193,7 @@
+ fi
+
+
++### --- libungif --- ###
+ AC_ARG_ENABLE(ungif,
+ [ --disable-ungif Disable libungif-based GIF support],,
+ enable_ungif=yes)
+@@ -250,6 +251,64 @@
+ fi
+ fi
+
++### --- giflib --- ###
++AC_ARG_ENABLE(giflib,
++ [ --enable-giflib Enable giflib-based GIF support],,
++ enable_giflib=no)
++
++AC_ARG_WITH(giflib_library,
++ [ --with-giflib-library=DIR GIFLIB library file are in DIR], ,
++ with_ungif_library=)
++AC_ARG_WITH(giflib_include,
++ [ --with-giflib-include=DIR GIFLIB include files are in DIR], ,
++ with_giflib_include=)
++
++if test "${enable_giflib}" = yes; then
++ orig_CPPFLAGS="${CPPFLAGS}"
++ orig_LDFLAGS="${LDFLAGS}"
++ orig_LIBS="${LIBS}"
++
++ if test -n "${with_giflib_library}"; then
++ with_giflib_library="-L$with_giflib_library"
++ fi
++ if test -n "${with_giflib_include}"; then
++ with_giflib_include="-I$with_giflib_include"
++ fi
++ CPPFLAGS="${with_giflib_include} ${CPPFLAGS}"
++ LDFLAGS="${with_giflib_library} ${LDFLAGS}"
++
++ AC_CHECK_LIB(gif, DGifOpen)
++
++ if test "${with_x}" != no && test "${ac_cv_lib_giflib_DGifOpen}" = no; then
++ AC_MSG_NOTICE([Checking if giflib is linked against -lX11])
++ # This implies either that giflib is not installed at all, or that it
++ # explicitly refers to the symbols defined in X11. Now see if the latter
++ # is the case.
++ CPPFLAGS="${CPPFLAGS} -I${ac_x_includes}"
++ LDFLAGS="${LDFLAGS} -L${ac_x_libraries}"
++ LIBS="${LIBS} -lX11"
++
++ AC_CHECK_LIB(gif, DGifCloseFile)
++ if test "${ac_cv_lib_giflib_DGifCloseFile}" = no; then
++ # This indicates giflib is not installed at all. The flags reverts to
++ # the orignal value.
++ CPPFLAGS="${orig_CPPFLAGS}"
++ LDFLAGS="${orig_LDFLAGS}"
++ LIBS="${orig_LIBS}"
++ else
++ # This indicates giflib actually refers to the X11's symbols. We modify
++ # the flags so that -gui gets linked against the X11 library to support
++ # giflib.
++ AC_MSG_NOTICE([-gui will be linked against -lX11 to support giflib images])
++ GRAPHIC_CFLAGS="-I${ac_x_includes} ${with_giflib_include} $GRAPHIC_CFLAGS"
++ GRAPHIC_LFLAGS="-L${ac_x_libraries} ${with_giflib_library} $GRAPHIC_LFLAGS"
++ fi
++ else
++ GRAPHIC_CFLAGS="${with_giflib_include} $GRAPHIC_CFLAGS"
++ GRAPHIC_LFLAGS="${with_giflib_library} $GRAPHIC_LFLAGS"
++ fi
++fi
++
+ #--------------------------------------------------------------------
+ # Check for the spelling lib, for the built-in spell checker...
+ #--------------------------------------------------------------------
diff --git a/gnustep-base/gnustep-gui/files/gui-use-giflib.patch.bz2 b/gnustep-base/gnustep-gui/files/gui-use-giflib.patch.bz2
deleted file mode 100644
index a5ea63f60976..000000000000
--- a/gnustep-base/gnustep-gui/files/gui-use-giflib.patch.bz2
+++ /dev/null
Binary files differ
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.9.4-r2.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.9.4-r2.ebuild
index b8845be52011..afe566b479f9 100644
--- a/gnustep-base/gnustep-gui/gnustep-gui-0.9.4-r2.ebuild
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.9.4-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.9.4-r2.ebuild,v 1.3 2005/07/16 15:49:54 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.9.4-r2.ebuild,v 1.4 2006/01/28 18:08:09 blubb Exp $
inherit gnustep
@@ -33,7 +33,7 @@ src_unpack() {
cd ${S}
EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/gui-def.patch
EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/gui-gsspell.patch
- EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/gui-use-giflib.patch.bz2
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/gui-use-giflib.patch
}
src_compile() {
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.9.5_pre20050312-r1.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.9.5_pre20050312-r1.ebuild
index d723af77e5ff..8ffea7484c8f 100644
--- a/gnustep-base/gnustep-gui/gnustep-gui-0.9.5_pre20050312-r1.ebuild
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.9.5_pre20050312-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.9.5_pre20050312-r1.ebuild,v 1.4 2005/07/16 15:49:54 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.9.5_pre20050312-r1.ebuild,v 1.5 2006/01/28 18:08:09 blubb Exp $
ECVS_CVS_COMMAND="cvs -q"
ECVS_SERVER="savannah.gnu.org:/cvsroot/gnustep"
@@ -40,7 +40,7 @@ egnustep_install_domain "System"
src_unpack() {
cvs_src_unpack ${A}
cd ${S}
- EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/gui-use-giflib.patch.bz2
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/gui-use-giflib.patch
}
src_compile() {