summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-09 18:52:57 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-09 18:52:57 +0000
commit956559f4183146237bfe4ad703e4512cfcf23a6b (patch)
tree22165246b343155ae88086e04dbb1a4d288fcb41 /gnustep-base
parentFix /etc/vim/vimrc so it does not accidentally override last-position-jump (B... (diff)
downloadgentoo-2-956559f4183146237bfe4ad703e4512cfcf23a6b.tar.gz
gentoo-2-956559f4183146237bfe4ad703e4512cfcf23a6b.tar.bz2
gentoo-2-956559f4183146237bfe4ad703e4512cfcf23a6b.zip
Revbump for EAPI=3, Prefix fixes, transferred Prefix keywords
(Portage version: 2.2.00.15800-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-make/ChangeLog8
-rw-r--r--gnustep-base/gnustep-make/files/gnustep-3.csh19
-rw-r--r--gnustep-base/gnustep-make/files/gnustep-3.sh23
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild81
4 files changed, 130 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-make/ChangeLog b/gnustep-base/gnustep-make/ChangeLog
index 78258df84f4b..ac2386b6f198 100644
--- a/gnustep-base/gnustep-make/ChangeLog
+++ b/gnustep-base/gnustep-make/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-make
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.87 2010/02/10 21:49:13 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.88 2010/03/09 18:52:57 grobian Exp $
+
+*gnustep-make-2.2.0-r1 (09 Mar 2010)
+
+ 09 Mar 2010; Fabian Groffen <grobian@gentoo.org>
+ +gnustep-make-2.2.0-r1.ebuild, +files/gnustep-3.csh, +files/gnustep-3.sh:
+ Revbump for EAPI=3, Prefix fixes, transferred Prefix keywords
10 Feb 2010; Bernard Cafarelli <voyageur@gentoo.org>
-gnustep-make-2.0.5.ebuild, -gnustep-make-2.0.6.ebuild,
diff --git a/gnustep-base/gnustep-make/files/gnustep-3.csh b/gnustep-base/gnustep-make/files/gnustep-3.csh
new file mode 100644
index 000000000000..064753d65330
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/gnustep-3.csh
@@ -0,0 +1,19 @@
+#!/usr/bin/env csh
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/files/gnustep-3.csh,v 1.1 2010/03/09 18:52:56 grobian Exp $
+
+# Test for an interactive shell
+if ( $?prompt ) then
+
+ setenv GNUSTEP_SYSTEM_TOOLS "@GENTOO_PORTAGE_EPREFIX@"/usr/GNUstep/System/Tools
+
+ if ( -x $GNUSTEP_SYSTEM_TOOLS/make_services ) then
+ $GNUSTEP_SYSTEM_TOOLS/make_services
+ endif
+
+ if ( -x $GNUSTEP_SYSTEM_TOOLS/gdnc ) then
+ $GNUSTEP_SYSTEM_TOOLS/gdnc
+ endif
+
+endif
diff --git a/gnustep-base/gnustep-make/files/gnustep-3.sh b/gnustep-base/gnustep-make/files/gnustep-3.sh
new file mode 100644
index 000000000000..6eb95c8fcf6b
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/gnustep-3.sh
@@ -0,0 +1,23 @@
+#!/usr/bin/env sh
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/files/gnustep-3.sh,v 1.1 2010/03/09 18:52:56 grobian Exp $
+
+# Test for an interactive shell
+case $- in
+ *i*)
+ ;;
+ *)
+ return
+ ;;
+esac
+
+GNUSTEP_SYSTEM_TOOLS="@GENTOO_PORTAGE_EPREFIX@"/usr/GNUstep/System/Tools
+
+if [ -x ${GNUSTEP_SYSTEM_TOOLS}/make_services ]; then
+ ${GNUSTEP_SYSTEM_TOOLS}/make_services
+fi
+
+if [ -x ${GNUSTEP_SYSTEM_TOOLS}/gdnc ]; then
+ ${GNUSTEP_SYSTEM_TOOLS}/gdnc
+fi
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..61c70139068a
--- /dev/null
+++ b/gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.2.0-r1.ebuild,v 1.1 2010/03/09 18:52:57 grobian Exp $
+
+EAPI="3"
+
+inherit gnustep-base eutils prefix
+
+DESCRIPTION="GNUstep Makefile Package"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="native-exceptions"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=sys-devel/gcc-3.3[objc]
+ >=sys-devel/make-3.75"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.1-destdir.patch
+ cp "${FILESDIR}"/gnustep-3.{csh,sh} "${T}"/
+ eprefixify "${T}"/gnustep-3.{csh,sh}
+}
+
+src_configure() {
+ local myconf
+ myconf="--prefix=${GNUSTEP_PREFIX} --with-layout=gnustep"
+ myconf="$myconf --with-config-file=${EPREFIX}/etc/GNUstep/GNUstep.conf"
+ myconf="$myconf $(use_enable native-exceptions native-objc-exceptions)"
+ econf $myconf || die "configure failed"
+}
+
+src_compile() {
+ emake || die "compilation failed"
+ # Prepare doc here (needed when no gnustep-make is already installed)
+ if use doc ; then
+ # If a gnustep-1 environment is set
+ unset GNUSTEP_MAKEFILES
+ cd Documentation
+ emake all install || die "doc make has failed"
+ cd ..
+ fi
+}
+
+src_install() {
+ # Get GNUSTEP_* variables
+ . ./GNUstep.conf
+
+ local make_eval
+ use debug || make_eval="${make_eval} debug=no"
+ make_eval="${make_eval} verbose=yes"
+
+ emake ${make_eval} DESTDIR="${D}" install || die "install has failed"
+
+ # Copy the documentation
+ if use doc ; then
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}
+ cp -r Documentation/tmp-installation/System/Library/Documentation \
+ "${ED}"${GNUSTEP_SYSTEM_LIBRARY}
+ fi
+
+ dodoc FAQ README RELEASENOTES
+
+ exeinto /etc/profile.d
+ doexe "${T}"/gnustep-3.sh
+ doexe "${T}"/gnustep-3.csh
+
+ dodir /etc/env.d
+ cat <<- EOF > "${ED}"/etc/env.d/99gnustep
+PATH=${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}
+ROOTPATH=${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}
+LDPATH=${GNUSTEP_SYSTEM_LIBRARIES}:${GNUSTEP_LOCAL_LIBRARIES}
+MANPATH=${GNUSTEP_SYSTEM_DOC_MAN}:${GNUSTEP_LOCAL_DOC_MAN}
+INFOPATH=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+INFODIR=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+EOF
+}