summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-11-27 19:41:02 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-11-27 19:41:02 +0000
commit5225357281e70a031bb1d49fafa18be8ddcdaad6 (patch)
tree52092fe76e40a804942f0f097409c35b88a9e161 /gnustep-base
parentMark stable since the underlying ruby-enterprise implementation is also marke... (diff)
downloadgentoo-2-5225357281e70a031bb1d49fafa18be8ddcdaad6.tar.gz
gentoo-2-5225357281e70a031bb1d49fafa18be8ddcdaad6.tar.bz2
gentoo-2-5225357281e70a031bb1d49fafa18be8ddcdaad6.zip
Use ssl USE-flag instead of gnutls
(Portage version: 2.2.0_alpha78/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-base/ChangeLog7
-rw-r--r--gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild10
-rw-r--r--gnustep-base/gnustep-base/gnustep-base-1.22.0.ebuild78
-rw-r--r--gnustep-base/gnustep-base/gnustep-base-1.22.1.ebuild8
4 files changed, 15 insertions, 88 deletions
diff --git a/gnustep-base/gnustep-base/ChangeLog b/gnustep-base/gnustep-base/ChangeLog
index a8bdbde97f4c..d36c5ce59234 100644
--- a/gnustep-base/gnustep-base/ChangeLog
+++ b/gnustep-base/gnustep-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-base/gnustep-base
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/ChangeLog,v 1.106 2011/09/29 22:05:28 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/ChangeLog,v 1.107 2011/11/27 19:41:02 voyageur Exp $
+
+ 27 Nov 2011; Bernard Cafarelli <voyageur@gentoo.org>
+ gnustep-base-1.20.1.ebuild, -gnustep-base-1.22.0.ebuild,
+ gnustep-base-1.22.1.ebuild:
+ Use ssl USE-flag instead of gnutls
*gnustep-base-1.22.1 (29 Sep 2011)
diff --git a/gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild b/gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild
index 5a5e1b52d0eb..978a95048e06 100644
--- a/gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild
+++ b/gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild,v 1.6 2010/08/13 17:29:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild,v 1.7 2011/11/27 19:41:02 voyageur Exp $
EAPI="3"
@@ -14,14 +14,14 @@ KEYWORDS="~alpha amd64 ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~s
SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
-IUSE="+libffi gnutls zeroconf"
+IUSE="+libffi ssl zeroconf"
RDEPEND="${GNUSTEP_CORE_DEPEND}
>=gnustep-base/gnustep-make-2.0.8
!libffi? ( dev-libs/ffcall
gnustep-base/gnustep-make[-native-exceptions] )
libffi? ( virtual/libffi )
- gnutls? ( net-libs/gnutls )
+ ssl? ( net-libs/gnutls )
>=dev-libs/libxml2-2.6
>=dev-libs/libxslt-1.1
>=dev-libs/gmp-4.1
@@ -44,7 +44,7 @@ src_configure() {
myconf="--disable-libffi --enable-ffcall"
fi
- myconf="$myconf $(use_enable gnutls tls)"
+ myconf="$myconf $(use_enable ssl tls)"
myconf="$myconf $(use_enable zeroconf)"
myconf="$myconf --with-xml-prefix=${EPREFIX}/usr"
myconf="$myconf --with-gmp-include=${EPREFIX}/usr/include --with-gmp-library=${EPREFIX}/usr/lib"
diff --git a/gnustep-base/gnustep-base/gnustep-base-1.22.0.ebuild b/gnustep-base/gnustep-base/gnustep-base-1.22.0.ebuild
deleted file mode 100644
index 433b09ab0978..000000000000
--- a/gnustep-base/gnustep-base/gnustep-base-1.22.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/gnustep-base-1.22.0.ebuild,v 1.2 2011/04/26 08:06:35 voyageur Exp $
-
-EAPI="3"
-
-inherit gnustep-base
-
-DESCRIPTION="A library of general-purpose, non-graphical Objective C objects."
-
-HOMEPAGE="http://www.gnustep.org"
-SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-
-IUSE="gnutls +icu +libffi zeroconf"
-
-RDEPEND="${GNUSTEP_CORE_DEPEND}
- >=gnustep-base/gnustep-make-2.6.0
- gnutls? ( net-libs/gnutls )
- icu? ( >=dev-libs/icu-4.0 )
- !libffi? ( dev-libs/ffcall
- gnustep-base/gnustep-make[-native-exceptions] )
- libffi? ( virtual/libffi )
- >=dev-libs/libxml2-2.6
- >=dev-libs/libxslt-1.1
- >=dev-libs/gmp-4.1
- >=dev-libs/openssl-0.9.7
- >=sys-libs/zlib-1.2
- zeroconf? ( || (
- net-dns/avahi[mdnsresponder-compat]
- net-misc/mDNSResponder ) )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_configure() {
- egnustep_env
-
- local myconf
- if use libffi;
- then
- myconf="--enable-libffi --disable-ffcall --with-ffi-include=$(pkg-config --variable=includedir libffi)"
- else
- myconf="--disable-libffi --enable-ffcall"
- fi
-
- myconf="$myconf $(use_enable icu)"
- myconf="$myconf $(use_enable gnutls tls)"
- myconf="$myconf $(use_enable zeroconf)"
- myconf="$myconf --with-xml-prefix=${EPREFIX}/usr"
- myconf="$myconf --with-gmp-include=${EPREFIX}/usr/include --with-gmp-library=${EPREFIX}/usr/lib"
- myconf="$myconf --with-default-config=${EPREFIX}/etc/GNUstep/GNUstep.conf"
-
- econf $myconf || die "configure failed"
-}
-
-src_install() {
- # We need to set LD_LIBRARY_PATH because the doc generation program
- # uses the gnustep-base libraries. Since egnustep_env "cleans the
- # environment" including our LD_LIBRARY_PATH, we're left no choice
- # but doing it like this.
-
- egnustep_env
- egnustep_install
-
- if use doc ; then
- export LD_LIBRARY_PATH="${S}/Source/obj:${LD_LIBRARY_PATH}"
- egnustep_doc
- fi
- egnustep_install_config
-}
-
-pkg_postinst() {
- ewarn "The shared library version has changed in this release."
- ewarn "You will need to recompile all Applications/Tools/etc in order"
- ewarn "to use this library. Please run revdep-rebuild to do so"
-}
diff --git a/gnustep-base/gnustep-base/gnustep-base-1.22.1.ebuild b/gnustep-base/gnustep-base/gnustep-base-1.22.1.ebuild
index 91ef26499f4d..01e6ece86798 100644
--- a/gnustep-base/gnustep-base/gnustep-base-1.22.1.ebuild
+++ b/gnustep-base/gnustep-base/gnustep-base-1.22.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/gnustep-base-1.22.1.ebuild,v 1.1 2011/09/29 22:05:28 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/gnustep-base-1.22.1.ebuild,v 1.2 2011/11/27 19:41:02 voyageur Exp $
EAPI="3"
@@ -14,15 +14,15 @@ KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linu
SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
-IUSE="gnutls +icu +libffi zeroconf"
+IUSE="+icu +libffi ssl zeroconf"
RDEPEND="${GNUSTEP_CORE_DEPEND}
>=gnustep-base/gnustep-make-2.6.0
- gnutls? ( net-libs/gnutls )
icu? ( >=dev-libs/icu-4.0 )
!libffi? ( dev-libs/ffcall
gnustep-base/gnustep-make[-native-exceptions] )
libffi? ( virtual/libffi )
+ ssl? ( net-libs/gnutls )
>=dev-libs/libxml2-2.6
>=dev-libs/libxslt-1.1
>=dev-libs/gmp-4.1
@@ -46,7 +46,7 @@ src_configure() {
fi
myconf="$myconf $(use_enable icu)"
- myconf="$myconf $(use_enable gnutls tls)"
+ myconf="$myconf $(use_enable ssl tls)"
myconf="$myconf $(use_enable zeroconf)"
myconf="$myconf --with-xml-prefix=${EPREFIX}/usr"
myconf="$myconf --with-gmp-include=${EPREFIX}/usr/include --with-gmp-library=${EPREFIX}/usr/lib"