summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-01-29 15:13:54 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-01-29 15:13:54 +0000
commit4f7aa67b77486707826661d399f9c67120c36039 (patch)
tree9efa040b183f798b4ae83b59b18a601f6c4b5a0e /gnustep-base
parentVersion bump (diff)
downloadgentoo-2-4f7aa67b77486707826661d399f9c67120c36039.tar.gz
gentoo-2-4f7aa67b77486707826661d399f9c67120c36039.tar.bz2
gentoo-2-4f7aa67b77486707826661d399f9c67120c36039.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-back-art/ChangeLog10
-rw-r--r--gnustep-base/gnustep-back-art/gnustep-back-art-0.24.0.ebuild84
2 files changed, 92 insertions, 2 deletions
diff --git a/gnustep-base/gnustep-back-art/ChangeLog b/gnustep-base/gnustep-back-art/ChangeLog
index 7bc39785586b..5c19ae0c2e40 100644
--- a/gnustep-base/gnustep-back-art/ChangeLog
+++ b/gnustep-base/gnustep-back-art/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-back-art
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-art/ChangeLog,v 1.91 2013/03/08 15:43:29 voyageur Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-art/ChangeLog,v 1.92 2014/01/29 15:13:54 voyageur Exp $
+
+*gnustep-back-art-0.24.0 (29 Jan 2014)
+
+ 29 Jan 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-back-art-0.24.0.ebuild:
+ Version bump
*gnustep-back-art-0.23.0 (08 Mar 2013)
diff --git a/gnustep-base/gnustep-back-art/gnustep-back-art-0.24.0.ebuild b/gnustep-base/gnustep-back-art/gnustep-back-art-0.24.0.ebuild
new file mode 100644
index 000000000000..5a1d5e674a6d
--- /dev/null
+++ b/gnustep-base/gnustep-back-art/gnustep-back-art-0.24.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-art/gnustep-back-art-0.24.0.ebuild,v 1.1 2014/01/29 15:13:54 voyageur Exp $
+
+EAPI=5
+inherit gnustep-base
+
+DESCRIPTION="libart_lgpl back-end component for the GNUstep GUI Library"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl xim"
+
+RDEPEND="${GNUSTEP_CORE_DEPEND}
+ =gnustep-base/gnustep-gui-${PV%.*}*
+ opengl? ( virtual/opengl virtual/glu )
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXft
+ x11-libs/libXrender
+ >=media-libs/freetype-2.1.9
+
+ >=media-libs/libart_lgpl-2.3
+ >=gnustep-base/mknfonts-0.5-r1
+ media-fonts/dejavu
+
+ !gnustep-base/gnustep-back-cairo
+ !gnustep-base/gnustep-back-xlib"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/gnustep-back-${PV}
+
+src_configure() {
+ egnustep_env
+
+ myconf="$(use_enable opengl glx)"
+ myconf="$myconf $(use_enable xim)"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=art"
+
+ econf $myconf
+}
+
+src_compile() {
+ gnustep-base_src_compile
+
+ # Create font lists for DejaVu
+ einfo "Generating nfonts support files"
+ (
+ cd Fonts
+ export "${GS_ENV[@]}"
+ ${GNUSTEP_SYSTEM_TOOLS}/mknfonts \
+ $(fc-list : file|grep -v '\.gz'|cut -d: -f1) \
+ || die "nfonts support files creation failed"
+ # Trim whitepsaces
+ for fdir in *\ */; do
+ mv "$fdir" `echo $fdir | tr -d [:space:]`
+ done
+ )
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ mkdir -p "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
+ cp -pPR Fonts/*.nfont "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
+}
+
+gnustep_config_script() {
+ echo "echo ' * setting normal font to DejaVuSans'"
+ echo "defaults write NSGlobalDomain NSFont DejaVuSans"
+ echo "echo ' * setting bold font to DejaVuSans-Bold'"
+ echo "defaults write NSGlobalDomain NSBoldFont DejaVuSans-Bold"
+ echo "echo ' * setting fixed font to DejaVuSansMono'"
+ echo "defaults write NSGlobalDomain NSUserFixedPitchFont DejaVuSansMono"
+}