summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-06-02 16:46:49 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-06-02 16:46:49 +0000
commit4bc163b35582948279f58dde48e4f624131d54b8 (patch)
tree9140e27b6529c70f06a4fb6fb9d7792e1d73420a /gnustep-base
parentAdd new gnustep-base revision to virtual/libffi mask (diff)
downloadgentoo-2-4bc163b35582948279f58dde48e4f624131d54b8.tar.gz
gentoo-2-4bc163b35582948279f58dde48e4f624131d54b8.tar.bz2
gentoo-2-4bc163b35582948279f58dde48e4f624131d54b8.zip
Use virtual/libffi instead of gcc[libffi], bug #272062
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-base/ChangeLog10
-rw-r--r--gnustep-base/gnustep-base/gnustep-base-1.18.0-r4.ebuild90
-rw-r--r--gnustep-base/gnustep-base/metadata.xml5
3 files changed, 100 insertions, 5 deletions
diff --git a/gnustep-base/gnustep-base/ChangeLog b/gnustep-base/gnustep-base/ChangeLog
index 04a3e13d13c4..b5ac0706a2d6 100644
--- a/gnustep-base/gnustep-base/ChangeLog
+++ b/gnustep-base/gnustep-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-base
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/ChangeLog,v 1.84 2009/03/24 13:16:57 voyageur Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/ChangeLog,v 1.85 2009/06/02 16:46:49 voyageur Exp $
+
+*gnustep-base-1.18.0-r4 (02 Jun 2009)
+
+ 02 Jun 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-base-1.18.0-r4.ebuild, metadata.xml:
+ Use virtual/libffi instead of gcc[libffi], bug #272062
24 Mar 2009; Bernard Cafarelli <voyageur@gentoo.org>
-gnustep-base-1.16.3-r1.ebuild, -gnustep-base-1.18.0-r1.ebuild,
diff --git a/gnustep-base/gnustep-base/gnustep-base-1.18.0-r4.ebuild b/gnustep-base/gnustep-base/gnustep-base-1.18.0-r4.ebuild
new file mode 100644
index 000000000000..661cb5ea2656
--- /dev/null
+++ b/gnustep-base/gnustep-base/gnustep-base-1.18.0-r4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/gnustep-base-1.18.0-r4.ebuild,v 1.1 2009/06/02 16:46:49 voyageur Exp $
+
+EAPI=2
+
+inherit autotools gnustep-base
+
+DESCRIPTION="A library of general-purpose, non-graphical Objective C objects."
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+IUSE="libffi gnutls zeroconf"
+
+RDEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-make-2.0.8
+ !libffi? ( dev-libs/ffcall
+ gnustep-base/gnustep-make[-native-exceptions] )
+ libffi? ( virtual/libffi )
+ gnutls? ( net-libs/gnutls )
+ >=dev-libs/libxml2-2.6
+ >=dev-libs/libxslt-1.1
+ >=dev-libs/gmp-4.1
+ >=dev-libs/openssl-0.9.7
+ >=sys-libs/zlib-1.2
+ zeroconf? ( || (
+ net-dns/avahi[mdnsresponder-compat]
+ net-misc/mDNSResponder ) )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Automagic dependency on mdns-responder
+ epatch "${FILESDIR}"/${P}-mdns_configure.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ egnustep_env
+
+ local myconf
+ if use libffi;
+ then
+ myconf="--enable-libffi --disable-ffcall --with-ffi-include=$(pkg-config --variable=includedir libffi)"
+ else
+ myconf="--disable-libffi --enable-ffcall"
+ fi
+
+ myconf="$myconf $(use_enable gnutls tls)"
+ myconf="$myconf $(use_enable zeroconf)"
+ myconf="$myconf --with-xml-prefix=/usr"
+ myconf="$myconf --with-gmp-include=/usr/include --with-gmp-library=/usr/lib"
+ myconf="$myconf --with-default-config=/etc/GNUstep/GNUstep.conf"
+
+ econf $myconf || die "configure failed"
+}
+
+src_install() {
+ # We need to set LD_LIBRARY_PATH because the doc generation program
+ # uses the gnustep-base libraries. Since egnustep_env "cleans the
+ # environment" including our LD_LIBRARY_PATH, we're left no choice
+ # but doing it like this.
+
+ egnustep_env
+ egnustep_install
+
+ if use doc ; then
+ export LD_LIBRARY_PATH="${S}/Source/obj:${LD_LIBRARY_PATH}"
+ egnustep_doc
+ fi
+ egnustep_install_config
+
+ dodir /etc/revdep-rebuild
+ sed -e 's|$GNUSTEP_SEARCH_DIRS|'"$GNUSTEP_SYSTEM_LIBRARIES $GNUSTEP_SYSTEM_TOOLS $GNUSTEP_LOCAL_LIBRARIES $GNUSTEP_LOCAL_TOOLS"'|' \
+ "${FILESDIR}"/50-gnustep-revdep \
+ > "${D}/etc/revdep-rebuild/50-gnustep-revdep"
+}
+
+pkg_postinst() {
+ ewarn "The shared library version has changed in this release."
+ ewarn "You will need to recompile all Applications/Tools/etc in order"
+ ewarn "to use this library."
+ ewarn "Run:"
+ ewarn "revdep-rebuild --library \"libgnustep-base.so.1.1[0-6]\""
+}
diff --git a/gnustep-base/gnustep-base/metadata.xml b/gnustep-base/gnustep-base/metadata.xml
index 1eed32da9900..ec4eb9c55595 100644
--- a/gnustep-base/gnustep-base/metadata.xml
+++ b/gnustep-base/gnustep-base/metadata.xml
@@ -13,8 +13,7 @@ It provides functionality that aims to implement the non-graphical
portion of the OpenStep standard (the Foundation library).
</longdescription>
<use>
- <flag name='gcc-libffi'>Use <pkg>dev-libs/libffi</pkg> from
- <pkg>sys-devel/gcc</pkg> instead of <pkg>dev-libs/ffcall</pkg>. Requires
- <pkg>sys-devel/gcc</pkg> built with USE=libffi</flag>
+ <flag name='gcc-libffi'>Use <pkg>dev-libs/libffi</pkg> from <pkg>sys-devel/gcc</pkg> instead of <pkg>dev-libs/ffcall</pkg>. Requires <pkg>sys-devel/gcc</pkg> built with USE=libffi</flag>
+ <flag name='libffi'>Use <pkg>dev-libs/libffi</pkg> instead of <pkg>dev-libs/ffcall</pkg></flag>
</use>
</pkgmetadata>