summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-12-22 13:59:13 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-12-22 13:59:13 +0000
commit1b23c12f87d5fe08c4924d4f9b514511782e4516 (patch)
tree62943729e2682deaf7c9176608c122218d1749c2 /gnustep-base
parentversion bump, see ChangeLog file for new features (diff)
downloadgentoo-2-1b23c12f87d5fe08c4924d4f9b514511782e4516.tar.gz
gentoo-2-1b23c12f87d5fe08c4924d4f9b514511782e4516.tar.bz2
gentoo-2-1b23c12f87d5fe08c4924d4f9b514511782e4516.zip
Major version bump, adds support for @synchronize, general OSX 10.5 compatibility, with small configure patch to fix broken check
(Portage version: 2.2_rc18/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-base/ChangeLog10
-rw-r--r--gnustep-base/gnustep-base/files/gnustep-base-1.18.0-unexpected_check.patch11
-rw-r--r--gnustep-base/gnustep-base/gnustep-base-1.18.0.ebuild82
3 files changed, 102 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-base/ChangeLog b/gnustep-base/gnustep-base/ChangeLog
index 74adf991c34c..87077647a597 100644
--- a/gnustep-base/gnustep-base/ChangeLog
+++ b/gnustep-base/gnustep-base/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnustep-base/gnustep-base
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/ChangeLog,v 1.78 2008/11/20 15:31:28 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/ChangeLog,v 1.79 2008/12/22 13:59:13 voyageur Exp $
+
+*gnustep-base-1.18.0 (22 Dec 2008)
+
+ 22 Dec 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +files/gnustep-base-1.18.0-unexpected_check.patch,
+ +gnustep-base-1.18.0.ebuild:
+ Major version bump, adds support for @synchronize, general OSX 10.5
+ compatibility, with small configure patch to fix broken check
*gnustep-base-1.16.5 (20 Nov 2008)
diff --git a/gnustep-base/gnustep-base/files/gnustep-base-1.18.0-unexpected_check.patch b/gnustep-base/gnustep-base/files/gnustep-base-1.18.0-unexpected_check.patch
new file mode 100644
index 000000000000..ec62842d9589
--- /dev/null
+++ b/gnustep-base/gnustep-base/files/gnustep-base-1.18.0-unexpected_check.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2008-12-22 14:28:19.000000000 +0100
++++ configure.ac 2008-12-22 14:28:31.000000000 +0100
+@@ -2007,7 +2007,7 @@
+ saved_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $OBJCFLAGS -x objective-c"
+ AC_MSG_CHECKING(for objc_set_unexpected() in runtime)
+-AC_COMPILE_IFELSE([#include "$srcdir/config/config.unexpected.m"],
++AC_LINK_IFELSE([#include "$srcdir/config/config.unexpected.m"],
+ have_unexpected=yes, have_unexpected=no)
+ if test $have_unexpected = yes; then
+ AC_DEFINE(HAVE_UNEXPECTED,1,
diff --git a/gnustep-base/gnustep-base/gnustep-base-1.18.0.ebuild b/gnustep-base/gnustep-base/gnustep-base-1.18.0.ebuild
new file mode 100644
index 000000000000..7fa1527265c7
--- /dev/null
+++ b/gnustep-base/gnustep-base/gnustep-base-1.18.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/gnustep-base-1.18.0.ebuild,v 1.1 2008/12/22 13:59:13 voyageur Exp $
+
+EAPI=2
+
+inherit gnustep-base autotools
+
+DESCRIPTION="A library of general-purpose, non-graphical Objective C objects."
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+IUSE="gcc-libffi gnutls"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-make-2.0
+ !gcc-libffi? ( dev-libs/ffcall )
+ gcc-libffi? ( >=sys-devel/gcc-3.3.5[libffi] )
+ gnutls? ( net-libs/gnutls )
+ >=dev-libs/libxml2-2.6
+ >=dev-libs/libxslt-1.1
+ >=dev-libs/gmp-4.1
+ >=dev-libs/openssl-0.9.7
+ >=sys-libs/zlib-1.2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-unexpected_check.patch
+ eautoreconf
+}
+
+src_configure() {
+ egnustep_env
+
+ local myconf
+ if use gcc-libffi;
+ then
+ myconf="--enable-libffi --disable-ffcall"
+ else
+ myconf="--disable-libffi --enable-ffcall"
+ fi
+
+ myconf="$myconf $(use_enable gnutls tls)"
+ myconf="$myconf --with-xml-prefix=/usr"
+ myconf="$myconf --with-gmp-include=/usr/include --with-gmp-library=/usr/lib"
+ myconf="$myconf --with-default-config=/etc/GNUstep/GNUstep.conf"
+
+ econf $myconf || die "configure failed"
+}
+
+src_install() {
+ # We need to set LD_LIBRARY_PATH because the doc generation program
+ # uses the gnustep-base libraries. Since egnustep_env "cleans the
+ # environment" including our LD_LIBRARY_PATH, we're left no choice
+ # but doing it like this.
+
+ egnustep_env
+ egnustep_install
+
+ if use doc ; then
+ export LD_LIBRARY_PATH="${S}/Source/obj:${LD_LIBRARY_PATH}"
+ egnustep_doc
+ fi
+ egnustep_install_config
+
+ dodir /etc/revdep-rebuild
+ sed -e 's|$GNUSTEP_SEARCH_DIRS|'"$GNUSTEP_SYSTEM_ROOT $GNUSTEP_LOCAL_ROOT"'|' \
+ "${FILESDIR}"/50-gnustep-revdep \
+ > "${D}/etc/revdep-rebuild/50-gnustep-revdep"
+}
+
+pkg_postinst() {
+ ewarn "The shared library version has changed in this release."
+ ewarn "You will need to recompile all Applications/Tools/etc in order"
+ ewarn "to use this library."
+ ewarn "Run:"
+ ewarn "revdep-rebuild --library \"libgnustep-base.so.1.1[0-6]\""
+}